This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Problem With SciPy Computation of sigma
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: berker.peksag, nisthesecond
Priority: normal Keywords:

Created on 2019-02-26 04:42 by nisthesecond, last changed 2022-04-11 14:59 by admin. This issue is now closed.

Files
File name Uploaded Description Edit
test_normal.py nisthesecond, 2019-02-26 04:42
Messages (2)
msg336604 - (view) Author: N. Srinivasan (nisthesecond) Date: 2019-02-26 04:42
"""
Construct  normal probability plot

"""
import math
import scipy.stats as ss
import numpy as np
import matplotlib.pyplot as plt
import seaborn as sns

import prettytable
from random import seed
seed(100)
################
mu = 0.0
sigma = 1.0
x = np.linspace(mu - 5*sigma, mu + 5*sigma, 10)
norm_pdf_x= ss.norm.pdf(x,mu,sigma)
plt.plot(x,norm_pdf_x)
print("The Std. Dev. of normally Dist. x =", np.std(norm_pdf_x))
print()
###########################################
Produces a wrong Result for sigma:
The Std. Dev. of normally Dist. x = 0.13142071847657633
Should be 1.0
msg336605 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2019-02-26 05:16
This tracker is for issues with the Python programming language and its standard library. SciPy is not part of the standard library. Please use SciPy project's support channels to get help for your problem. Thank you!
History
Date User Action Args
2022-04-11 14:59:11adminsetgithub: 80294
2019-02-26 05:16:06berker.peksagsetstatus: open -> closed

nosy: + berker.peksag
messages: + msg336605

resolution: not a bug
stage: resolved
2019-02-26 04:42:25nisthesecondcreate