classification
Title: ^ used in inaccurate example in regex-howto
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.8, Python 3.7, Python 3.6, Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Wrong statement about ^ in howto/regex.rst
View: 35584
Assigned To: docs@python Nosy List: docs@python, eric.araujo, ezio.melotti, louism, mdk, willingc
Priority: normal Keywords:

Created on 2019-02-19 14:41 by louism, last changed 2019-02-19 16:35 by mdk. This issue is now closed.

Messages (2)
msg335953 - (view) Author: Louis Michael (louism) * Date: 2019-02-19 14:41
at https://docs.python.org/3/howto/regex.html#regex-howto
and
https://docs.python.org/3.8/howto/regex.html#regex-howto
https://docs.python.org/3.7/howto/regex.html#regex-howto
https://docs.python.org/3.6/howto/regex.html#regex-howto
https://docs.python.org/3.5/howto/regex.html#regex-howto
https://docs.python.org/3.4/howto/regex.html#regex-howto
https://docs.python.org/2.7/howto/regex.html#regex-howto

The following paragraph seems to have a small issue:
"
You can match the characters not listed within the class by complementing the set. This is indicated by including a '^' as the first character of the class; '^' outside a character class will simply match the '^' character. For example, [^5] will match any character except '5'.
"
^ does not simply match ^ outside a character class since is a special character that represents the start of the string. 

I think the paragraph should read: 
You can match the characters not listed within the class by complementing the set. This is indicated by including a '^' as the first character of the class; '^' will act differently outside a character class as explained later. For example, [^5] will match any character except '5'.
msg335972 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2019-02-19 16:35
Hi, thanks for reporting!

It's a duplicate of https://bugs.python.org/issue35584, so I'm closing it, but if you feed like opening a PR on it, it would be appreciated.

Bests.
History
Date User Action Args
2019-02-19 16:35:21mdksetstatus: open -> closed
superseder: Wrong statement about ^ in howto/regex.rst
messages: + msg335972

resolution: duplicate
stage: resolved
2019-02-19 14:41:06louismcreate