This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Incorrect __text_signature__ for the __get__ slot wrapper
Type: behavior Stage: resolved
Components: Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: SilentGhost, bup
Priority: normal Keywords:

Created on 2019-02-13 00:42 by bup, last changed 2022-04-11 14:59 by admin. This issue is now closed.

Messages (2)
msg335378 - (view) Author: Dan Snider (bup) * Date: 2019-02-13 00:42
The current signature:

    "__get__($self, instance, owner, /)\n--\n\nReturn an attribute of instance, which is of type owner."

doens't match how wrap_descr_get actually parses the arguments to __get__ with:

    PyArg_UnpackTuple(args, "", 1, 2, &obj, &type)
msg335393 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2019-02-13 07:55
Is it not? This seems to be doing exactly what's intended. If you have a reproducible bug trigger, please post it, but I'll close the issue in the meantime.
History
Date User Action Args
2022-04-11 14:59:11adminsetgithub: 80160
2019-02-13 07:55:55SilentGhostsetstatus: open -> closed

type: behavior

nosy: + SilentGhost
messages: + msg335393
resolution: not a bug
stage: resolved
2019-02-13 00:42:47bupcreate