classification
Title: Update libffi_msvc to current version of libffi
Type: enhancement Stage: resolved
Components: ctypes, Windows Versions: Python 3.8
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: Paul Monson, SilentGhost, paul.moore, petr.viktorin, serhiy.storchaka, steve.dower, tim.golden, vstinner, zach.ware
Priority: normal Keywords: patch, patch, patch, patch

Created on 2019-02-08 22:40 by Paul Monson, last changed 2019-06-03 09:22 by petr.viktorin. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 11797 merged Paul Monson, 2019-02-09 00:21
PR 11797 merged Paul Monson, 2019-02-09 00:21
PR 11797 merged Paul Monson, 2019-02-09 00:21
PR 11797 merged Paul Monson, 2019-02-09 00:21
PR 12629 merged ZackerySpytz, 2019-03-30 09:19
Messages (8)
msg335115 - (view) Author: Paul Monson (Paul Monson) * Date: 2019-02-08 22:40
libffi needs to be updated to the current version for Windows builds to make it easier to add ARM support
msg339161 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-03-29 23:30
New changeset 32119e10b792ad7ee4e5f951a2d89ddbaf111cc5 by Steve Dower (Paul Monson) in branch 'master':
bpo-35947: Update Windows to the current version of libffi (GH-11797)
https://github.com/python/cpython/commit/32119e10b792ad7ee4e5f951a2d89ddbaf111cc5
msg339264 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2019-03-31 16:00
New changeset 48600c72c1afe1096c2412a135a43f8cdd895195 by Serhiy Storchaka (Zackery Spytz) in branch 'master':
bpo-35947: Fix a compiler warning in _ctypes.c's StructUnionType_paramfunc(). (GH-12629)
https://github.com/python/cpython/commit/48600c72c1afe1096c2412a135a43f8cdd895195
msg342167 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-05-11 06:39
Would it be possible to add a What's New in Python 3.8 entry about this change? IMHO it is big and important enough to be mentioned ;-) I also wanted libffi_msvc/ to be removed. Thanks!
msg342169 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2019-05-11 06:49
> I also wanted libffi_msvc/ to be removed.

An empty directory is not really tracked by git, you should be able to just remove it manually without any problems, alternatively you could try

git clean -fd  # on a clean tree

add -n for dry run.
msg342210 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-05-11 17:17
I am talking about the commit whixh removed the directory. I am happy that
someone succeeded to write it ;-)
msg342743 - (view) Author: Paul Monson (Paul Monson) * Date: 2019-05-17 17:35
Would you like me to submit a PR to the What's New doc?
msg344395 - (view) Author: Petr Viktorin (petr.viktorin) * (Python committer) Date: 2019-06-03 09:22
Possible regression caused by this change: https://bugs.python.org/issue37140
History
Date User Action Args
2019-06-03 09:22:13petr.viktorinsetkeywords: patch, patch, patch, patch
nosy: + petr.viktorin
messages: + msg344395

2019-05-17 17:35:37Paul Monsonsetmessages: + msg342743
2019-05-11 17:17:20vstinnersetmessages: + msg342210
2019-05-11 06:49:29SilentGhostsetkeywords: patch, patch, patch, patch
nosy: + SilentGhost
messages: + msg342169

2019-05-11 06:39:57vstinnersetkeywords: patch, patch, patch, patch
nosy: + vstinner
messages: + msg342167

2019-05-03 16:02:20Paul Monsonsetstatus: open -> closed
stage: patch review -> resolved
2019-03-31 16:00:17serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg339264
2019-03-30 09:19:24ZackerySpytzsetpull_requests: + pull_request12562
2019-03-29 23:30:12steve.dowersetmessages: + msg339161
2019-02-09 00:21:42Paul Monsonsetkeywords: + patch
stage: patch review
pull_requests: + pull_request11805
2019-02-09 00:21:32Paul Monsonsetkeywords: + patch
stage: (no value)
pull_requests: + pull_request11806
2019-02-09 00:21:21Paul Monsonsetkeywords: + patch
stage: (no value)
pull_requests: + pull_request11804
2019-02-09 00:21:13Paul Monsonsetkeywords: + patch
stage: (no value)
pull_requests: + pull_request11803
2019-02-08 22:40:46Paul Monsoncreate