classification
Title: the test suite of pytest failed with 3.8.0a1
Type: Stage: resolved
Components: Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: gvanrossum, matrixise, paul.moore
Priority: normal Keywords:

Created on 2019-02-04 14:22 by matrixise, last changed 2019-02-05 11:51 by matrixise. This issue is now closed.

Files
File name Uploaded Description Edit
tox-pytest-38-stdout.log matrixise, 2019-02-04 14:22
Messages (6)
msg334823 - (view) Author: Stéphane Wirtel (matrixise) * (Python committer) Date: 2019-02-04 14:22
I have execute the tests of pytest with 3.8.0a1 and I get some issues, it's not the case with 3.7.x (see the travis logs of pytest, https://travis-ci.org/pytest-dev/pytest/branches) 

I am going to create the same issue for pytest.
msg334824 - (view) Author: Stéphane Wirtel (matrixise) * (Python committer) Date: 2019-02-04 14:23
Here is the issue in the bug tracker of pytest

https://github.com/pytest-dev/pytest/issues/4716
msg334825 - (view) Author: Paul Moore (paul.moore) * (Python committer) Date: 2019-02-04 14:57
Is this relevant? https://bugs.python.org/issue33416 It's a backward incompatible change to the AST in 3.8 (according to the 3.8 changelog).
msg334826 - (view) Author: Stéphane Wirtel (matrixise) * (Python committer) Date: 2019-02-04 15:03
maybe, I don't know but I have tested with pytest because the tests with requests did not work.

I prefered to create this issue and the same issue on the bug tracker of pytest.
msg334833 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2019-02-04 17:33
Looks like pytest needs to be adjusted to some new AST features.
msg334862 - (view) Author: Stéphane Wirtel (matrixise) * (Python committer) Date: 2019-02-05 11:51
Hi Guido,

The team of Pytest has been informed and after a small discussion, it seems it's a problem with the way they use the AST for the assert keyword. They know the issue, I hope they will fix it asap.

I would like to test pytest with 3.8 ;-)

Thank you to closing this one.
History
Date User Action Args
2019-02-05 11:51:55matrixisesetmessages: + msg334862
2019-02-04 17:33:35gvanrossumsetstatus: open -> closed

nosy: + gvanrossum
messages: + msg334833

resolution: not a bug
stage: resolved
2019-02-04 15:03:10matrixisesetmessages: + msg334826
2019-02-04 14:57:17paul.mooresetnosy: + paul.moore
messages: + msg334825
2019-02-04 14:23:59matrixisesetmessages: + msg334824
2019-02-04 14:22:27matrixisecreate