classification
Title: Don't log an exception from the main coroutine in asyncio.run()
Type: Stage: resolved
Components: asyncio Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: asvetlov, dmzz, eamanu, scotchka, yselivanov
Priority: normal Keywords: easy

Created on 2019-01-24 00:58 by asvetlov, last changed 2019-02-21 18:20 by asvetlov. This issue is now closed.

Files
File name Uploaded Description Edit
utils.py asvetlov, 2019-01-24 00:58
Messages (4)
msg334276 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2019-01-24 00:58
We use `asyncio.run()` (well, a backported to python3.6 private copy) in our application.

The problem is: when `asyncio.run(main_coro(args))` raises an exception it is both raised to a caller and passed to `loop.call_exception_handler()` by `_cancel_all_tasks()` as *unhandled exception*.

I believe that the logging of unhandled exceptions is a very useful feature but the logging should be skipped for the main coroutine passed to `asyncio.run()` because it is handled by outer code anyway.

The fix is trivial, the attached file shows how to do it.
But the fix needs tests also.

If somebody wishes to pick up the issue and make it done -- it would be awesome. I will help with review and commit, sure.

Another question is should the changing land into 3.7?
I think yes but feedback from Yuri Selivanov is very welcome.
msg334903 - (view) Author: Henry Chen (scotchka) * Date: 2019-02-06 06:16
I'm having trouble reproducing this issue. The main_coro seems to disappear when an exception is raised in it, so that it does not show up in the set of tasks to cancel. I'm probably misunderstanding something basic here. Is it possible to provide a minimal example?
msg336180 - (view) Author: Carlos Damázio (dmzz) Date: 2019-02-21 03:37
Hey, Andrew. I'd like to work on the issue, if anyone else hasn't done it yet.
msg336248 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2019-02-21 18:20
Nevermind.

Actually, I used a backport `asyncio.run()` to Python 3.6.
I saw the problem because of the difference between `asyncio.all_task()` and `asyncio.Task.all_task()`.

The former return only active tasks but the later returns done tasks also.
History
Date User Action Args
2019-02-21 18:20:52asvetlovsetstatus: open -> closed
stage: resolved
2019-02-21 18:20:39asvetlovsetresolution: not a bug
messages: + msg336248
2019-02-21 03:37:03dmzzsetnosy: + dmzz
messages: + msg336180
2019-02-20 10:57:17eamanusetnosy: + eamanu
2019-02-06 06:16:48scotchkasetnosy: + scotchka
messages: + msg334903
2019-01-24 00:58:51asvetlovcreate