classification
Title: openssl version 1.1.1 need to be there in cpython-source-deps for windows ARM64
Type: enhancement Stage: resolved
Components: SSL, Windows Versions: Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: Paul Monson, christian.heimes, ossdev07, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2019-01-15 07:41 by ossdev07, last changed 2019-03-07 16:39 by steve.dower. This issue is now closed.

Messages (3)
msg333649 - (view) Author: ossdev (ossdev07) * Date: 2019-01-15 07:45
as per in https://github.com/openssl/openssl/issues/6856 , for windows on ARM64 we need to switch to Openssl 1.1.1
msg333650 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2019-01-15 07:49
3.7 uses OpenSSL 1.1.0. OpenSSL 1.1.1 adds TLS 1.3 and behaves differently than 1.1.0. We cannot update 3.7 to 1.1.1 because it would break backwards compatibility. For 3.8, we can move to 1.1.1.

You either have to compile your own Python and OpenSSL 1.1.1 on Windows, convince OpenSSL upstream to fix 1.1.0, or wait until 3.8 comes out by the end of the year.
msg337403 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-03-07 16:39
It's there now (and about to move to 1.1.1b :) )
History
Date User Action Args
2019-03-07 16:39:34steve.dowersetstatus: open -> closed
resolution: fixed
messages: + msg337403

stage: resolved
2019-02-07 02:49:03Paul Monsonsetnosy: + Paul Monson
2019-01-15 07:49:11christian.heimessetversions: + Python 3.8, - Python 3.7
nosy: + paul.moore, tim.golden, zach.ware, steve.dower

messages: + msg333650

assignee: christian.heimes ->
components: + Windows
2019-01-15 07:45:24ossdev07setmessages: + msg333649
2019-01-15 07:41:43ossdev07settitle: ssl version 1.1.1 need to be there in cpython-source-deps for windows ARM64 -> openssl version 1.1.1 need to be there in cpython-source-deps for windows ARM64
2019-01-15 07:41:18ossdev07create