classification
Title: Typo in library/warnings documentation
Type: Stage: resolved
Components: Documentation Versions: Python 3.8, Python 3.7, Python 3.6, Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Doc: warnings.rst - add links to references
View: 35563
Assigned To: docs@python Nosy List: awecx, cheryl.sabella, docs@python, eric.araujo, ezio.melotti, mdk, pablogsal, willingc
Priority: normal Keywords: patch, patch, patch, patch

Created on 2019-01-13 23:18 by awecx, last changed 2019-01-14 19:08 by cheryl.sabella. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 11549 closed awecx, 2019-01-14 08:23
PR 11549 closed awecx, 2019-01-14 08:23
PR 11549 closed awecx, 2019-01-14 08:23
PR 11549 closed awecx, 2019-01-14 08:23
Messages (5)
msg333574 - (view) Author: Antoine Wecxsteen (awecx) * Date: 2019-01-13 23:18
Hello,

I believe there's a mistake in the documentation of library/warnings.

https://docs.python.org/3.8/library/warnings.html#warnings.warn

"This function raises an exception if the particular warning issued is changed into an error by the warnings filter see above."

I think "see above" should be enclosed in brackets (or maybe completely removed as there is already a "(see above)" in the same text block).

Regards.
msg333576 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2019-01-14 00:46
That looks like an error indeed. Are you interested on making a PR for fixing this?
msg333589 - (view) Author: Antoine Wecxsteen (awecx) * Date: 2019-01-14 08:15
Hello Pablo,

Yes, I'll be happy to make a PR.

I don't think it should be removed after all as, actually, the two "see above" do not refer to the same paragraph ("Warning Categories" and "The Warnings Filter" respectively).
msg333590 - (view) Author: Antoine Wecxsteen (awecx) * Date: 2019-01-14 08:28
https://github.com/python/cpython/pull/11549

Reading the dev guide, I see there is actually no need to open an issue for mere typos. I should have made a PR directly...
msg333636 - (view) Author: Cheryl Sabella (cheryl.sabella) * (Python committer) Date: 2019-01-14 19:08
Closing as a duplicate of #35563, which converts the 'see above' to links.
History
Date User Action Args
2019-01-14 19:08:34cheryl.sabellasetkeywords: patch, patch, patch, patch
nosy: + cheryl.sabella
messages: + msg333636

2019-01-14 19:07:42cheryl.sabellasetkeywords: patch, patch, patch, patch
status: open -> closed
superseder: Doc: warnings.rst - add links to references
resolution: duplicate
stage: patch review -> resolved
2019-01-14 08:28:39awecxsetmessages: + msg333590
2019-01-14 08:24:01awecxsetkeywords: + patch
stage: patch review
pull_requests: + pull_request11174
2019-01-14 08:23:49awecxsetkeywords: + patch
stage: (no value)
pull_requests: + pull_request11173
2019-01-14 08:23:37awecxsetkeywords: + patch
stage: (no value)
pull_requests: + pull_request11172
2019-01-14 08:23:26awecxsetkeywords: + patch
stage: (no value)
pull_requests: + pull_request11171
2019-01-14 08:15:25awecxsetmessages: + msg333589
2019-01-14 00:46:39pablogsalsetnosy: + pablogsal
messages: + msg333576
2019-01-13 23:18:01awecxcreate