classification
Title: with closed file descriptor #2 (stderr), py3k hangs when trying to print an exception
Type: crash Stage:
Components: Interpreter Core Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, gvanrossum, pitrou
Priority: high Keywords:

Created on 2008-08-16 22:20 by pitrou, last changed 2008-08-16 23:52 by pitrou. This issue is now closed.

Messages (3)
msg71244 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2008-08-16 22:20
Reproducing this bug is simple:

./python -c "import os; os.close(2); 1/0"
msg71247 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-08-16 23:11
Curious. I wonder if this is platform specific because this does not
hang for me on MacOS.
msg71250 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2008-08-16 23:52
Hmm, sorry, false alarm. This was due to some debugging code I had added
in my working copy.
History
Date User Action Args
2008-08-16 23:52:22pitrousetstatus: open -> closed
resolution: not a bug
messages: + msg71250
2008-08-16 23:11:36benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg71247
2008-08-16 22:57:16gvanrossumsetnosy: + gvanrossum
2008-08-16 22:20:57pitroucreate