classification
Title: Add use_srcentry parameter to shutil.copytree() II
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: flokX, giampaolo.rodola
Priority: normal Keywords: patch

Created on 2019-01-03 18:57 by flokX, last changed 2019-02-26 11:04 by giampaolo.rodola. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 11425 closed flokX, 2019-01-03 19:04
PR 11997 merged giampaolo.rodola, 2019-02-23 17:14
Messages (3)
msg332941 - (view) Author: (flokX) * Date: 2019-01-03 18:57
Currently it is decided if to use the srcentry in the copy_function by checking if the copy_function is copy() or copy2(). This will fail if the copy_function is a modified copy() or copy2() function. To control if the copy_function gets a srcentry or srcname parameter, added the use_srcentry parameter.

Successor of https://bugs.python.org/issue35648
msg336387 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2019-02-23 16:36
Not sure why you created 2 identical issues. Closing this one as a duplicate of issue35648.
msg336645 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2019-02-26 11:04
New changeset c606a9cbd48f69d3f4a09204c781dda9864218b7 by Giampaolo Rodola in branch 'master':
bpo-35652: shutil.copytree(copy_function=...) erroneously pass DirEntry instead of path str (GH-11997)
https://github.com/python/cpython/commit/c606a9cbd48f69d3f4a09204c781dda9864218b7
History
Date User Action Args
2019-02-26 11:04:47giampaolo.rodolasetmessages: + msg336645
2019-02-23 17:14:29giampaolo.rodolasetpull_requests: + pull_request12024
2019-02-23 16:36:54giampaolo.rodolasetpull_requests: - pull_request12023
2019-02-23 16:36:46giampaolo.rodolasetstatus: open -> closed

nosy: + giampaolo.rodola
messages: + msg336387

resolution: duplicate
stage: patch review -> resolved
2019-02-23 15:16:23giampaolo.rodolasetpull_requests: + pull_request12023
2019-01-03 19:04:25flokXsetkeywords: + patch
stage: patch review
pull_requests: + pull_request10846
2019-01-03 18:57:45flokXcreate