classification
Title: Intel compiler (icc) does not fully support C11 Features, including atomics
Type: compile error Stage: resolved
Components: Build, ctypes, Installation, Library (Lib) Versions: Python 3.7, Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Error build Python with Intel compiler: <stdatomic.h> doesn't provide atomic_uintptr_t
View: 37415
Assigned To: Nosy List: hairygristle, jamie schnaitter, josh.r, vstinner
Priority: normal Keywords:

Created on 2018-12-12 17:50 by jamie schnaitter, last changed 2019-10-21 10:07 by vstinner. This issue is now closed.

Messages (3)
msg331713 - (view) Author: jamie schnaitter (jamie schnaitter) Date: 2018-12-12 17:50
I am currently trying to build 3.6.7 and 3.7.1 using Intel 2019 and it is failing because Intel's implementation of C11, in particular stdatomic, is incomplete.  I receive many errors similar to the following, when it cannot find 'atomic_uintptr_t', which is not including in Intel's implementation:

```
In file included from ./Include/Python.h(56),
                 from ./Modules/_io/bufferedio.c(11):
./Include/pyatomic.h(33): error: identifier "atomic_uintptr_t" is undefined
      atomic_uintptr_t _value;
```

The current check in configure.ac is insufficient, as it only checks to see that the header and library exist and that it contains 'atomic_int'.  The configure.ac should be changed to either check for all the atomic types it uses (or at least atomic_uintprt_t) or, when `--with-icc` is enabled, it should set 'HAVE_STD_ATOMIC' to 0/false.
msg338807 - (view) Author: Josh Rosenberg (josh.r) * (Python triager) Date: 2019-03-25 15:56
Perhaps an alternative solution would be to provide conditional definitions for the stuff ICC leaves out? I'm assuming ICC can actually handle _Atomic uintptr_t if you type it out, it's just missing the typedef for it for whatever reason?
msg355038 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-10-21 10:07
I mark this issue as a duplicate of bpo-37415.
History
Date User Action Args
2019-10-21 10:07:24vstinnersetstatus: open -> closed

superseder: Error build Python with Intel compiler: <stdatomic.h> doesn't provide atomic_uintptr_t

nosy: + vstinner
messages: + msg355038
resolution: duplicate
stage: resolved
2019-03-25 15:56:42josh.rsetnosy: + josh.r
messages: + msg338807
2019-03-25 07:09:12hairygristlesetnosy: + hairygristle
2018-12-12 17:50:27jamie schnaittercreate