classification
Title: ctypes works on Intel OS X, fails on PPC OS X
Type: behavior Stage:
Components: Library (Lib) Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: janssen
Priority: normal Keywords:

Created on 2008-08-11 18:37 by janssen, last changed 2008-08-12 01:53 by janssen. This issue is now closed.

Messages (2)
msg71028 - (view) Author: Bill Janssen (janssen) * (Python committer) Date: 2008-08-11 18:37
Hi, I'm having more problems with ctypes.util.find_library.  On my
Intel box, this works fine:

% python
Python 2.5.1 (r251:54863, Jan 17 2008, 19:35:17) 
[GCC 4.0.1 (Apple Inc. build 5465)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> from ctypes import CDLL, RTLD_GLOBAL
>>> from ctypes.util import find_library
>>> print CDLL(find_library("iconv"), RTLD_GLOBAL)
<CDLL '/usr/lib/libiconv.dylib', handle 311df0 at 8a1b0>
>>> 

But on my PowerPC box, I get this:

% python
Python 2.5.1 (r251:54863, Jan 17 2008, 19:35:16) 
[GCC 4.0.1 (Apple Inc. build 5465)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> from ctypes import CDLL, RTLD_GLOBAL
>>> from ctypes.util import find_library
>>> print CDLL(find_library("iconv"), RTLD_GLOBAL)
<CDLL 'None', handle fffffffe at 75af0>
>>> 

Both have /usr/lib/libiconv.dylib, both are running 10.5.4.
msg71041 - (view) Author: Bill Janssen (janssen) * (Python committer) Date: 2008-08-12 01:53
Caused by setting DYLD_FALLBACK_LIBRARY_PATH badly on the PPC machine.
History
Date User Action Args
2008-08-12 01:53:10janssensetstatus: open -> closed
resolution: not a bug
messages: + msg71041
2008-08-11 18:37:57janssencreate