classification
Title: collections.abc.Sequence isn't an abstract base class for array.array
Type: behavior Stage: resolved
Components: Versions: Python 3.8, Python 3.7, Python 3.6, Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: array is not a Sequence
View: 25737
Assigned To: Nosy List: Leonard de Ruijter, serhiy.storchaka
Priority: normal Keywords:

Created on 2018-11-29 15:05 by Leonard de Ruijter, last changed 2018-11-29 18:16 by serhiy.storchaka. This issue is now closed.

Messages (3)
msg330695 - (view) Author: Leonard de Ruijter (Leonard de Ruijter) Date: 2018-11-29 15:05
array.array seems to have all the abstract methods of a collections.abc.Sequence and all the classes it inherits from, still the following returns False:
`isinstance(array.array("u"), collections.abc.Sequence)`
msg330702 - (view) Author: Leonard de Ruijter (Leonard de Ruijter) Date: 2018-11-29 16:56
This might be a duplicate of https://bugs.python.org/issue35190
msg330706 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-11-29 18:16
See issue23864, issue25737 and issue35190.
History
Date User Action Args
2018-11-29 18:16:39serhiy.storchakasetstatus: open -> closed

superseder: array is not a Sequence

nosy: + serhiy.storchaka
messages: + msg330706
resolution: duplicate
stage: resolved
2018-11-29 16:56:05Leonard de Ruijtersetmessages: + msg330702
2018-11-29 15:05:12Leonard de Ruijtercreate