classification
Title: Misc/README.valgrind out-of-date
Type: Stage: resolved
Components: Documentation Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Valgrind documentation seems to need updating
View: 32666
Assigned To: docs@python Nosy List: cheryl.sabella, docs@python, rrh
Priority: normal Keywords:

Created on 2018-11-02 18:08 by rrh, last changed 2018-11-02 22:15 by cheryl.sabella. This issue is now closed.

Messages (2)
msg329151 - (view) Author: Robert Henry (rrh) Date: 2018-11-02 18:08
File Misc/README.valgrind is out of date with respect to python3.8.  There are important sections of this file that are 15 years old!

Example: the README.valgrind refers to "Uncomment Py_USING_MEMORY_DEBUGGER in Objects/obmalloc.c" but there's no such symbol in obmalloc.c (There is in Python/dtoa.c)

I have no idea if the valgrind suppression file Misc/valgrind-python.supp is up to date, but it bears examination by an expert.
msg329167 - (view) Author: Cheryl Sabella (cheryl.sabella) * (Python committer) Date: 2018-11-02 22:15
Thank you for the report.  Closing as a duplicate of issue32666.
History
Date User Action Args
2018-11-02 22:15:45cheryl.sabellasetstatus: open -> closed

superseder: Valgrind documentation seems to need updating

nosy: + cheryl.sabella
messages: + msg329167
resolution: duplicate
stage: resolved
2018-11-02 18:08:52rrhcreate