classification
Title: distutils fails with mingw binutils 2.18.50.20080109
Type: behavior Stage:
Components: Distutils Versions: Python 3.0, Python 2.6, Python 2.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: amaury.forgeotdarc Nosy List: amaury.forgeotdarc, benjamin.peterson, paul.moore
Priority: critical Keywords: patch

Created on 2008-08-03 16:12 by paul.moore, last changed 2008-08-18 19:26 by amaury.forgeotdarc. This issue is now closed.

Files
File name Uploaded Description Edit
distutils.patch paul.moore, 2008-08-03 16:12
Messages (3)
msg70655 - (view) Author: Paul Moore (paul.moore) * (Python committer) Date: 2008-08-03 16:12
The latest version of Mingw binutils, 2.18.50.20080109, uses a 4-part
version number which distutils does not like (StrictVersion only allows
for 3 parts).

The attached patch fixes this, simply by using LooseVersion (the version
number has already been checked to be a series of numbers in the regex
check just previous).

Can this be fixed for 2.6/3.0, as it is likely that the new binutils
will become common while these versions of Python are current?
msg71337 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-08-18 14:52
Amaury, if you are going to look at this you might want to see #2234.
msg71363 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-08-18 19:26
Yes, this problem is a duplicate of #2234, for which I had a very
similar fix.
Thanks!
History
Date User Action Args
2008-08-18 19:26:42amaury.forgeotdarcsetstatus: open -> closed
resolution: fixed
messages: + msg71363
2008-08-18 14:52:25benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg71337
2008-08-18 13:43:04amaury.forgeotdarcsetassignee: amaury.forgeotdarc
nosy: + amaury.forgeotdarc
2008-08-03 18:40:48pitrousetpriority: critical
versions: + Python 2.6, Python 3.0
2008-08-03 16:12:55paul.moorecreate