classification
Title: ntpath.abspath no longer uses normpath
Type: behavior Stage: resolved
Components: Library (Lib), Windows Versions: Python 3.7, Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: paul.moore, rhwlo, steve.dower, tim.golden, xtreak, zach.ware
Priority: normal Keywords:

Created on 2018-10-10 02:41 by rhwlo, last changed 2018-11-10 02:58 by eryksun. This issue is now closed.

Messages (2)
msg327452 - (view) Author: joshu coats (rhwlo) Date: 2018-10-10 02:41
After the changes from https://github.com/python/cpython/pull/8544, ntpath.abspath no longer calls normpath on the output of nt._getfullpathname. This unfortunately causes "python setup.py develop" on a project to become upset in some instances because two paths (which should be equal) differ by a trailing slash.

Presumably this could be corrected by updating https://github.com/python/cpython/blob/0185f34ddcf07b78feb6ac666fbfd4615d26b028/Lib/ntpath.py#L526 to use normpath when it calls _getfullpathname.
msg329582 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python triager) Date: 2018-11-10 01:15
Thanks for the report. I think this was a regression reported in https://bugs.python.org/issue31047#msg328322 and was fixed with  https://github.com/python/cpython/pull/10082 . I think the regression was in 3.7.1 but the fix was made a little later that it was not part of the 3.7.1 release.
History
Date User Action Args
2018-11-10 02:58:30eryksunsetstatus: open -> closed
resolution: fixed
stage: resolved
2018-11-10 01:15:33xtreaksetnosy: + xtreak
messages: + msg329582
2018-10-10 02:41:14rhwlocreate