classification
Title: asyncio documention has lost its paragraph about cancellation
Type: enhancement Stage: resolved
Components: asyncio, Documentation Versions: Python 3.8, Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: amirouche, asvetlov, docs@python, yselivanov
Priority: normal Keywords:

Created on 2018-10-03 12:07 by amirouche, last changed 2018-11-08 12:24 by asvetlov. This issue is now closed.

Messages (4)
msg326966 - (view) Author: Amirouche Boubekki (amirouche) Date: 2018-10-03 12:07
The paragraph was still there in 3.6 https://docs.python.org/3.6/library/asyncio-dev.html#cancellation
msg326967 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2018-10-03 12:11
Yuri, can you take a look?
msg326973 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2018-10-03 14:30
The cancellation is now discussed in this section:https://docs.python.org/3/library/asyncio-task.html (search for "cancel") and in particular in the Task subsection.

Is there any important detail that was covered in the old documentation and is missing in the new one?
msg329468 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2018-11-08 12:24
I think the issue can be closed
History
Date User Action Args
2018-11-08 12:24:26asvetlovsetstatus: open -> closed
resolution: not a bug
messages: + msg329468

stage: resolved
2018-10-03 14:30:06yselivanovsetmessages: + msg326973
2018-10-03 12:11:27asvetlovsetmessages: + msg326967
2018-10-03 12:08:24amirouchesettitle: asycnio documention has lost its paragraph about cancellation -> asyncio documention has lost its paragraph about cancellation
2018-10-03 12:07:59amirouchecreate