classification
Title: Heap-allocated StructSequences
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.8, Python 3.7, Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: eelizondo, josh.r, pablogsal, petr.viktorin
Priority: normal Keywords: patch

Created on 2018-09-24 07:23 by eelizondo, last changed 2018-12-05 12:10 by petr.viktorin. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 9524 closed eelizondo, 2018-09-24 07:31
PR 9665 merged eelizondo, 2018-10-02 16:07
PR 10536 merged pablogsal, 2018-11-14 01:03
Messages (5)
msg326205 - (view) Author: Eddie Elizondo (eelizondo) * Date: 2018-09-24 07:23
PyStructSequence_NewType does not currently work. Read the full analysis here: https://mail.python.org/pipermail/python-dev/2018-September/155069.html

This aims to fix the implementation of PyStructSequence_NewType.
msg326946 - (view) Author: Josh Rosenberg (josh.r) * (Python triager) Date: 2018-10-03 08:18
This looks like a duplicate of #28709, though admittedly, that bug hasn't seen any PRs.
msg329834 - (view) Author: Petr Viktorin (petr.viktorin) * (Python committer) Date: 2018-11-13 12:09
New changeset 474eedfb3d1b6fecbd749f36bf4a987cf4a00b44 by Petr Viktorin (Eddie Elizondo) in branch 'master':
bpo-34784: Fix PyStructSequence_NewType with heap-allocated StructSequence (GH-9665)
https://github.com/python/cpython/commit/474eedfb3d1b6fecbd749f36bf4a987cf4a00b44
msg329882 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2018-11-14 01:19
PR9665 solves also Issue28709
msg329939 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2018-11-15 02:04
New changeset bfb855bef6b428d639693caaf4e4c84cbb8a2f51 by Pablo Galindo in branch 'master':
bpo-34784: Implement correct cleanup in PyStructSequence new implementation (GH-10536)
https://github.com/python/cpython/commit/bfb855bef6b428d639693caaf4e4c84cbb8a2f51
History
Date User Action Args
2018-12-05 12:10:25petr.viktorinsetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2018-11-15 02:04:00pablogsalsetmessages: + msg329939
2018-11-14 01:19:46pablogsalsetnosy: + pablogsal
messages: + msg329882
2018-11-14 01:03:15pablogsalsetpull_requests: + pull_request9787
2018-11-13 12:09:34petr.viktorinsetnosy: + petr.viktorin
messages: + msg329834
2018-10-03 08:18:34josh.rsetnosy: + josh.r
messages: + msg326946
2018-10-02 16:07:44eelizondosetpull_requests: + pull_request9062
2018-09-24 07:31:45eelizondosetkeywords: + patch
stage: patch review
pull_requests: + pull_request8929
2018-09-24 07:23:17eelizondocreate