classification
Title: Python will suddenly not plot
Type: crash Stage: resolved
Components: Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ammar2, heihaa
Priority: normal Keywords:

Created on 2018-09-22 20:13 by heihaa, last changed 2018-09-22 20:41 by ammar2. This issue is now closed.

Messages (2)
msg326112 - (view) Author: heiahh (heihaa) Date: 2018-09-22 20:13
Hi! I am experience a very strange behavior. As a student I've been using Spyder for my Python coding assignments. But some days ago I wanted to try out the Python environment in Visual Studio. So, I installed python environment in VS. But after that, none of even my simplest codes will produce any plots anymore. Even if I try the exact same code as I for sure know been showing a plot before. Initally I had a error message saying something like "mkl_aa_fw_init_workdivision...." + some more info and directory reference. So after some googling I deleted a mkl file in the directory witch was mentioned in the error message. After that there is no error message, but still no plot. If I try a simple test code like this:

import matplotlib.pyplot as plt
import numpy as np
x = np.linspace(0,5,11)
y = x**2
plt.plot(x,y)

The only thing happening is Ipython console says "Kernel died, restarting". Also in Visual Studio, there is no plot coming up.I have no idea about the cause and how to fix it, even after hours of search and trial. Really frustrating to use time on this instead of my assignments. The only difference befor, when it was working, and after, is that I tried the Visual Studio environment. I highly appreciate help on this issue!
msg326113 - (view) Author: Ammar Askar (ammar2) * (Python triager) Date: 2018-09-22 20:41
Hey heiahh,

This bug tracker is for issues pertaining to the python interpreter itself. You'd be better off asking your question on the matplotlib bug tracker or stack overflow:

https://github.com/matplotlib/matplotlib/issues

https://stackoverflow.com/
History
Date User Action Args
2018-09-22 20:41:47ammar2setstatus: open -> closed

nosy: + ammar2
messages: + msg326113

resolution: not a bug
stage: resolved
2018-09-22 20:13:09heihaacreate