classification
Title: pathlib path.match misshandles multiple `**`
Type: Stage: resolved
Components: Library (Lib) Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Pathlib glob ** bug
View: 29249
Assigned To: Nosy List: Ronny.Pfannschmidt, berker.peksag
Priority: normal Keywords:

Created on 2018-09-19 05:34 by Ronny.Pfannschmidt, last changed 2018-09-19 09:01 by berker.peksag. This issue is now closed.

Messages (3)
msg325701 - (view) Author: Ronny Pfannschmidt (Ronny.Pfannschmidt) Date: 2018-09-19 05:34
when porting parts of pytest to pathlib we noted that `path.match` does not quite match normal fnmatch for usages of `**`

i believe this is related to always splitting the patter completely and not handling `**` in that case

Bruno wrote https://github.com/pytest-dev/pytest/pull/3980/files#diff-63fc5ed688925b327a5af20405bf4b09R19 as a workaround
msg325703 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2018-09-19 06:11
Thanks for the report. This looks like a duplicate of issue 29249.
msg325734 - (view) Author: Ronny Pfannschmidt (Ronny.Pfannschmidt) Date: 2018-09-19 08:13
indeed it is, thanks for the reference i searched only for match and missed the glob
History
Date User Action Args
2018-09-19 09:01:05berker.peksagsetsuperseder: Pathlib glob ** bug
2018-09-19 08:13:51Ronny.Pfannschmidtsetstatus: open -> closed
resolution: duplicate
messages: + msg325734

stage: resolved
2018-09-19 06:11:36berker.peksagsetnosy: + berker.peksag
messages: + msg325703
2018-09-19 05:34:46Ronny.Pfannschmidtcreate