classification
Title: Windows/2.7.15 IOError [Errno 0] when user interacts with cmd console
Type: behavior Stage: resolved
Components: IO, Windows Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: OSError: raw write() returned invalid length on latest Win 10 Consoles
View: 32245
Assigned To: Nosy List: cowlinator, eryksun, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2018-09-18 19:54 by cowlinator, last changed 2018-09-18 21:42 by eryksun. This issue is now closed.

Messages (4)
msg325676 - (view) Author: cowlinator (cowlinator) Date: 2018-09-18 19:54
I can consistently reproduce a bug in 2.7.15 on Windows which causes an unexpected IOError.

Steps to reproduce:

Enter the following code in a plain-vanilla windows command line console:

>>> import sys
>>> while True:
...     sys.stdout.write('.')

Then, pause the output, either by clicking and holding the scrollbar for 10 seconds, or by highlighting text with the mouse for 10 seconds and then pressing 'enter' to un-highlight.
Upon resuming, the following error is seen:

Traceback (most recent call last):
  File "<stdin>", line 2, in <module>
IOError: [Errno 0] Error
msg325680 - (view) Author: Eryk Sun (eryksun) * (Python triager) Date: 2018-09-18 20:36
This may be the same problem as issue 32245, which was a third-party bug that Microsoft fixed in the last Spring update of Windows 10. Which version of Windows are you using?
msg325681 - (view) Author: cowlinator (cowlinator) Date: 2018-09-18 20:59
I think you are probably right.  
I'm using Windows 10 Version 1709 (OS Build 16299.611)
msg325683 - (view) Author: Eryk Sun (eryksun) * (Python triager) Date: 2018-09-18 21:42
With Windows 10 release 1803, I can't reproduce either this problem or the problems from issue 32245. I'm marking this issue closed as a duplicate. Open a new issue if you still experience the problem after updating to Windows 10 release 1803 or 1809.
History
Date User Action Args
2018-09-18 21:42:20eryksunsetstatus: open -> closed
superseder: OSError: raw write() returned invalid length on latest Win 10 Consoles
messages: + msg325683

resolution: duplicate
stage: resolved
2018-09-18 20:59:11cowlinatorsetmessages: + msg325681
2018-09-18 20:36:52eryksunsetnosy: + eryksun
messages: + msg325680
2018-09-18 19:54:36cowlinatorcreate