classification
Title: allow path-like objects in program arguments in Windows
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.8, Python 3.7, Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: subprocess._execute_child doesn't accept a single PathLike argument for args
View: 31961
Assigned To: Nosy List: guoci, serhiy.storchaka
Priority: normal Keywords: patch

Created on 2018-09-15 19:20 by guoci, last changed 2018-11-09 08:07 by serhiy.storchaka. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 9336 closed guoci, 2018-09-15 19:24
Messages (2)
msg325454 - (view) Author: Guo Ci Teo (guoci) * Date: 2018-09-15 19:20
Currently, the `subprocess.Popen` function allows for path-like objects in the argument list for POSIX but not in Windows.
This PR makes Windows' `subprocess.Popen` accept path-like objects in the argument list.
msg325458 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-09-15 21:12
This looks like a duplicate of issue31961.
History
Date User Action Args
2018-11-09 08:07:29serhiy.storchakasetstatus: open -> closed
stage: patch review -> resolved
2018-09-15 21:12:15serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg325458
resolution: duplicate

superseder: subprocess._execute_child doesn't accept a single PathLike argument for args
2018-09-15 20:19:24guocisettitle: allows path-like objects in program arguments in Windows -> allow path-like objects in program arguments in Windows
2018-09-15 19:24:37guocisetkeywords: + patch
stage: patch review
pull_requests: + pull_request8760
2018-09-15 19:20:16guocicreate