classification
Title: Python & NCURSES
Type: compile error Stage:
Components: None Versions: Python 2.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, nandha
Priority: normal Keywords:

Created on 2008-07-29 06:49 by nandha, last changed 2008-07-29 07:28 by amaury.forgeotdarc. This issue is now closed.

Messages (2)
msg70377 - (view) Author: nandhakumar (nandha) Date: 2008-07-29 06:49
i have installed python 2.4 and ncurses 5.4 in my linux server.
 
Python script is working fine but when i tried using thread function in
my script(which also uses ncurses) it gives the following error: 

 
Traceback (most recent call last):
  File "xxxx.py", line 199, in ?
    curses.wrapper(AnDoRun)
  File "/usr/local/lib/python2.4/curses/wrapper.py", line 44, in wrapper
    return func(stdscr, *args, **kwds)
  File "xxxx.py", line 182, in AnDoRun
    ando.start()
  File "xxxx.py", line 136, in start
    self.proxyManagerThread.start()
  File "/usr/local/lib/python2.4/threading.py", line 416, in start
    _start_new_thread(self.__bootstrap, ())
thread.error: can't start new thread

help me how can i solve this problem ASAP
msg70379 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-07-29 07:28
The python issue tracker is not the correct place to get this kind of
help. Please ask on the comp.lang.python newsgroup:
http://www.python.org/community/lists
History
Date User Action Args
2008-07-29 07:28:55amaury.forgeotdarcsetstatus: open -> closed
resolution: not a bug
messages: + msg70379
nosy: + amaury.forgeotdarc
2008-07-29 06:49:55nandhacreate