classification
Title: IDLE: Make TextView use the configured theme colors
Type: enhancement Stage: resolved
Components: IDLE Versions: Python 3.8, Python 3.7, Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: taleinat Nosy List: cheryl.sabella, miss-islington, taleinat, terry.reedy
Priority: normal Keywords: patch

Created on 2018-08-30 12:39 by taleinat, last changed 2018-09-23 16:38 by terry.reedy. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 9008 merged taleinat, 2018-08-30 12:45
PR 9513 merged miss-islington, 2018-09-23 12:23
PR 9514 merged miss-islington, 2018-09-23 12:23
Messages (10)
msg326121 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-09-23 01:08
I am about to review and test, including live testing on Windows, with an eye to merging before the Monday midnight deadline for the coming releases.  At the moment I have no personal preference, nor insight into likely user perferences.

Tal, what is your rationale for the proposal?  Personal preference? Do you think a majority of user will prefer this?  Have you hand-tested (or htested) on both Mac and Linux?

Cheryl, what do you think?
msg326124 - (view) Author: Cheryl Sabella (cheryl.sabella) * (Python committer) Date: 2018-09-23 01:22
I did a review on the PR which probably answers your question, but I'll summarize here.

I think consistency in the windows would be good.  Consistency would include (but not limited to) foreground and background color, font style, font size, and behavior such as resizing.  If a user has changed to a dark theme with a font size of 20, then opening up the help or find windows should use that.

So, I think this is a good suggestion, but I think it should be considered within a larger scope.
msg326125 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-09-23 01:49
Investigating the code, I discovered that
  # TODO: get fg/bg from theme."
is my rewrite on 2016 8 31, a3623c8, of
  #elguavas - config placeholders til config stuff completed
Stephen Gava either wrote or modified the file in 2001.  Using the config settings was the original intention, and I thought two years ago and in subsequent revisions that we should at least try it.
msg326131 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-09-23 04:04
After live testing, I like 'after' at least as well as 'before'.  I also decided that people who selects a dark theme because black on white is obnoxious to their eyes should have their choice on all text panes.
msg326139 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-09-23 06:34
The first follow-up, #34774, makes the help viewer use the current theme. It would be good if it were separately tested on Linux/Mac, as it uses multiple tags.
msg326150 - (view) Author: miss-islington (miss-islington) Date: 2018-09-23 12:23
New changeset c87d9f406bb23657c1b4cd63017bb7bd7693a1fb by Miss Islington (bot) (Tal Einat) in branch 'master':
bpo-34548: IDLE: use configured theme colors in TextView (GH-9008)
https://github.com/python/cpython/commit/c87d9f406bb23657c1b4cd63017bb7bd7693a1fb
msg326152 - (view) Author: miss-islington (miss-islington) Date: 2018-09-23 13:31
New changeset aeadf59e457ca0ee20983eb1ed78b348f0b453e3 by Miss Islington (bot) in branch '3.7':
bpo-34548: IDLE: use configured theme colors in TextView (GH-9008)
https://github.com/python/cpython/commit/aeadf59e457ca0ee20983eb1ed78b348f0b453e3
msg326153 - (view) Author: miss-islington (miss-islington) Date: 2018-09-23 13:31
New changeset 6b48f9854e2ae35fd74bcd359451eb37ae65f798 by Miss Islington (bot) in branch '3.6':
bpo-34548: IDLE: use configured theme colors in TextView (GH-9008)
https://github.com/python/cpython/commit/6b48f9854e2ae35fd74bcd359451eb37ae65f798
msg326154 - (view) Author: Tal Einat (taleinat) * (Python committer) Date: 2018-09-23 13:33
Thanks for the review, discussion and approval, Cheryl and Terry!
msg326165 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-09-23 16:38
I removed 2.7 because I stopped routinely backporting to 2.7 some time ago because a) renaming files (which could not be backported) and using ttk widgets (ditto) made it much harder, and b) it was empirically too easy to introduce regressions without *thorough* hand testing. Given that most beginners now start with 3.x, I prefer merging more patches for current 3.x.
History
Date User Action Args
2018-09-23 16:38:19terry.reedysettype: enhancement
messages: + msg326165
2018-09-23 13:33:30taleinatsetstatus: open -> closed
resolution: fixed
messages: + msg326154

stage: patch review -> resolved
2018-09-23 13:31:55miss-islingtonsetmessages: + msg326153
2018-09-23 13:31:40miss-islingtonsetmessages: + msg326152
2018-09-23 12:23:48miss-islingtonsetpull_requests: + pull_request8920
2018-09-23 12:23:40miss-islingtonsetstage: commit review -> patch review
pull_requests: + pull_request8919
2018-09-23 12:23:23miss-islingtonsetnosy: + miss-islington
messages: + msg326150
2018-09-23 06:34:17terry.reedysetpriority: low -> normal

messages: + msg326139
2018-09-23 04:08:29terry.reedylinkissue33396 dependencies
2018-09-23 04:04:46terry.reedysetstage: patch review -> commit review
2018-09-23 04:04:24terry.reedysetmessages: + msg326131
2018-09-23 01:49:31terry.reedysetmessages: + msg326125
2018-09-23 01:22:59cheryl.sabellasetmessages: + msg326124
2018-09-23 01:08:54terry.reedysetnosy: + cheryl.sabella

messages: + msg326121
versions: - Python 2.7
2018-08-30 12:45:47taleinatsetkeywords: + patch
stage: patch review
pull_requests: + pull_request8478
2018-08-30 12:39:32taleinatcreate