classification
Title: Memory leak on _testCongestion
Type: behavior Stage: resolved
Components: Interpreter Core Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_socket: testCongestion() hangs on my Fedora 28
View: 34587
Assigned To: Nosy List: Vinicius Pacheco, petr.viktorin, xtreak, yan12125
Priority: normal Keywords:

Created on 2018-08-08 05:21 by Vinicius Pacheco, last changed 2018-09-14 20:58 by petr.viktorin. This issue is now closed.

Messages (3)
msg323262 - (view) Author: Vinicius Pacheco (Vinicius Pacheco) Date: 2018-08-08 05:21
Following this document https://devguide.python.org/ to compile the python I've got a memory leak on the test _testCongestion. This test is on the file Lib/test/test_socket.py.

The line that show me the issue is:

while True:
    self.cli.sendto(self.data, 0, (HOST, self.port))

The process enters on the "while" and never finish. I'm using a Fedora 28 on this test.
msg324669 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python triager) Date: 2018-09-06 07:55
Seems related : https://bugs.python.org/issue34587

Thanks
msg325399 - (view) Author: Petr Viktorin (petr.viktorin) * (Python committer) Date: 2018-09-14 20:58
That issue has more information/discussion, and it does look like the same bug, so I'll close this one.

Thank you for reporting it!
History
Date User Action Args
2018-09-14 20:58:02petr.viktorinsetstatus: open -> closed

superseder: test_socket: testCongestion() hangs on my Fedora 28

nosy: + petr.viktorin
messages: + msg325399
resolution: duplicate
stage: resolved
2018-09-07 13:51:57yan12125setnosy: + yan12125
2018-09-06 07:55:09xtreaksetnosy: + xtreak
messages: + msg324669
2018-08-08 05:21:01Vinicius Pachecocreate