This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Python 3.7 - Issues Installing Scikit Learn
Type: compile error Stage: resolved
Components: Library (Lib) Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: abhishekreddyc, mark.dickinson
Priority: normal Keywords:

Created on 2018-08-07 14:55 by abhishekreddyc, last changed 2022-04-11 14:59 by admin. This issue is now closed.

Messages (2)
msg323243 - (view) Author: Abhishek Reddy (abhishekreddyc) Date: 2018-08-07 14:55
Hi

I am currently encountering below issues when trying to install any version of Scikit Learn (0.19.0 or 0.19.1 or 0.19.2) on Linux - RHEL / Centos 7 OS. 

Few months back I could successfully install scikit-learn under python 2.7 without issues. When I re-run the installation of scikit-learn package under python 2.7 its failing with the same below error.

I have installed all the required dependencies of OS and Python packages for scikit-learn

Python Version - 3.7

/usr/local/bsb-python37 - Custom Location in which I configured and installed Python 3.7

I have installed all the prerequisite - OS packages - bias-devel , lapack-devel , atlas-devel. 

Earlier when I installed Python 2.7 I didn't run into any issues. Now when I re-try to install the scikit learn under Python 2.7 I am running into the same issue and the earlier successful installed version of scikit learn is corrupted.

Error
# /usr/local/bsb-python37/bin/python3.7 setup.py install --prefix=/usr/local/bsb-python37
Partial import of sklearn during the build process.
blas_opt_info:
blas_mkl_info:
customize UnixCCompiler
  libraries mkl_rt not found in ['/usr/local/bsb-python37/lib', '/usr/local/lib64', '/usr/local/lib', '/usr/lib64', '/usr/lib', '/usr/lib/']
  NOT AVAILABLE

blis_info:
customize UnixCCompiler
  libraries blis not found in ['/usr/local/bsb-python37/lib', '/usr/local/lib64', '/usr/local/lib', '/usr/lib64', '/usr/lib', '/usr/lib/']
  NOT AVAILABLE

  error: Command "g++ -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -fPIC -I/usr/local/bsb-python37/lib/python3.7/site-packages/numpy-1.14.5-py3.7-linux-x86_64.egg/numpy/core/include -I/usr/local/bsb-python37/lib/python3.7/site-packages/numpy-1.14.5-py3.7-linux-x86_64.egg/numpy/core/include -I/usr/local/bsb-python37/include/python3.7m -c sklearn/cluster/_dbscan_inner.cpp -o build/temp.linux-x86_64-3.7/sklearn/cluster/_dbscan_inner.o -MMD -MF build/temp.linux-x86_64-3.7/sklearn/cluster/_dbscan_inner.o.d" failed with exit status 1

Any help is greatly appreciated. I tried to google around and did all that I could try. No luck.

Thanks,
Abhishek
msg323245 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2018-08-07 15:24
Closing as duplicate of #34348.
History
Date User Action Args
2022-04-11 14:59:04adminsetgithub: 78532
2018-08-07 15:24:36mark.dickinsonsetstatus: open -> closed

nosy: + mark.dickinson
messages: + msg323245

resolution: duplicate
stage: resolved
2018-08-07 14:55:20abhishekreddyccreate