classification
Title: Mac, 2.6 framework install error
Type: compile error Stage: resolved
Components: macOS Versions: Python 2.6
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: lanny, robind, ronaldoussoren
Priority: normal Keywords:

Created on 2008-07-24 02:42 by robind, last changed 2010-01-17 19:15 by ronaldoussoren. This issue is now closed.

Messages (3)
msg70189 - (view) Author: Robin Dunn (robind) Date: 2008-07-24 02:42
OSX Leopard (10.5.4)
Python-2.6b2 tarball

./configure --enable-universalsdk --enable-framework 
make
sudo make install 

Ends with this error:

cd Mac && make installmacsubtree DESTDIR=""
Creating directory
/Library/Frameworks/Python.framework/Versions/2.6/Mac/Tools
DYLD_FRAMEWORK_PATH=/projects/Python-2.6b2: arch -ppc -i386
../python.exe ./scripts/cachersrc.py -v
/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-mac
/Library/Frameworks/Python.framework/Versions/2.6/Mac/Tools
Traceback (most recent call last):
  File "./scripts/cachersrc.py", line 7, in <module>
    import macresource
  File "/projects/Python-2.6b2/Lib/plat-mac/macresource.py", line 6, in
<module>
    from Carbon import Res
  File "/projects/Python-2.6b2/Lib/plat-mac/Carbon/Res.py", line 4, in
<module>
    from _Res import *
ImportError: No module named _Res
make[1]: *** [installmacsubtree] Error 1
make: *** [frameworkinstallmaclib] Error 2


Since by this time in the install process the _Res module has already
been installed I was able to work around this issue by hacking the
generated Mac/Makefile and setting RUNSHARED to nothing.  The same
problem happens in Mac/IDLE/Makefile as well.
msg78463 - (view) Author: Alan Brooks (lanny) Date: 2008-12-29 16:48
I also get this exact same problem. Mac OS 10.5.6 on an Intel MacBook 
trying to install the release version of 2.6.1. I found it was failing to 
build _Res, but worked around by *not* using --enable-universalsdk.
msg96139 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2009-12-08 16:44
Is this issue still relevant? I cannot reproduce this on my machines.
History
Date User Action Args
2010-01-17 19:15:28ronaldoussorensetstatus: open -> closed
resolution: works for me
stage: resolved
2009-12-08 16:44:21ronaldoussorensetnosy: + ronaldoussoren
messages: + msg96139
2008-12-29 16:48:15lannysetnosy: + lanny
messages: + msg78463
2008-07-24 02:42:53robindcreate