classification
Title: find_python.bat doesn't find installed Python 3.7
Type: behavior Stage: resolved
Components: Windows Versions: Python 3.8, Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: steve.dower Nosy List: Segev Finer, miss-islington, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords: patch

Created on 2018-07-28 23:33 by Segev Finer, last changed 2018-09-21 20:25 by steve.dower. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 8552 merged steve.dower, 2018-07-29 13:21
PR 9373 merged miss-islington, 2018-09-17 21:42
Messages (3)
msg322597 - (view) Author: Segev Finer (Segev Finer) * Date: 2018-07-28 23:33
The PCbuild/find_python.bat script doesn't find an installed Python 3.7 and will proceed to download Python using nuget.

This is caused by it invoking py with "-3.6" which will only find Python 3.6 (py doesn't seem to support a 3.6 or above flag), despite the fact that the build can use 3.7 and the nuget fallback will install 3.7.
msg325583 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-09-17 21:41
New changeset 6750922f8d3428d84a016c34d6fcd99659e8610c by Steve Dower in branch 'master':
bpo-34267: Update find_python.bat to use 3.7 if available (GH-8552)
https://github.com/python/cpython/commit/6750922f8d3428d84a016c34d6fcd99659e8610c
msg325591 - (view) Author: miss-islington (miss-islington) Date: 2018-09-17 22:39
New changeset a8a8cc71c7fc7585e15652ff7ab354665f787d5a by Miss Islington (bot) in branch '3.7':
bpo-34267: Update find_python.bat to use 3.7 if available (GH-8552)
https://github.com/python/cpython/commit/a8a8cc71c7fc7585e15652ff7ab354665f787d5a
History
Date User Action Args
2018-09-21 20:25:11steve.dowersetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2018-09-17 22:39:28miss-islingtonsetnosy: + miss-islington
messages: + msg325591
2018-09-17 21:42:09miss-islingtonsetpull_requests: + pull_request8796
2018-09-17 21:41:56steve.dowersetmessages: + msg325583
2018-07-29 13:21:48steve.dowersetkeywords: + patch
stage: patch review
pull_requests: + pull_request8068
2018-07-29 13:15:37steve.dowersetassignee: steve.dower
2018-07-28 23:33:17Segev Finercreate