classification
Title: Inconsistency between stack size in main thread and secondary threads on macOS
Type: enhancement Stage: resolved
Components: Interpreter Core, macOS Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Re-enable threading test on macOS
View: 18049
Assigned To: Nosy List: ned.deily, ronaldoussoren
Priority: normal Keywords: patch

Created on 2018-07-28 16:00 by ronaldoussoren, last changed 2019-07-13 14:14 by ronaldoussoren. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 8534 closed ronaldoussoren, 2018-07-28 16:26
Messages (3)
msg322569 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2018-07-28 16:00
configure.ac sets the stack size for the main thread on macOS to 1000000 (hex), while Python/threading_pthread.h sets the default stack size for other threads to 0x500000. The latter is half of the former.

IMHO both should be the same, as both claim to have been chosen to be just large enough to accommodate the default recursion limit. 

I'd prefer to increase the default stack size of secondary threads to match the main thread. I tagged this as a 3.8 thread because there is a (very) small chance that changing the stack size breaks existing programs (although you'd have to create a lot of threads to use a significant amount of memory). 

This is vaguely related to issue33955.
msg322573 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2018-07-28 16:06
PS. A pull request will follow shortly.
msg347825 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2019-07-13 14:13
This is a duplicate of 18049, which has a more complete patch.
History
Date User Action Args
2019-07-13 14:14:06ronaldoussorensetstatus: open -> closed
2019-07-13 14:13:58ronaldoussorensetsuperseder: Re-enable threading test on macOS
resolution: duplicate
messages: + msg347825
stage: patch review -> resolved
2018-07-28 16:26:00ronaldoussorensetkeywords: + patch
stage: needs patch -> patch review
pull_requests: + pull_request8051
2018-07-28 16:06:13ronaldoussorensetmessages: + msg322573
2018-07-28 16:00:44ronaldoussorencreate