classification
Title: Python3.7.0 exe installers (32 and 64 bit) failing on Windows7
Type: Stage: resolved
Components: Installation, Windows Versions: Python 3.7
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: paul.moore, steve.dower, tim.golden, wolma, zach.ware
Priority: normal Keywords:

Created on 2018-07-26 10:15 by wolma, last changed 2019-08-02 22:53 by steve.dower. This issue is now closed.

Files
File name Uploaded Description Edit
Python 3.7.0 (64-bit)_20180726120531.log wolma, 2018-07-26 10:16
Python 3.7.0 (64-bit)_20180731180657_000_core_JustForMe.log wolma, 2018-07-31 16:10
Python 3.7.0 (64-bit)_20180731180657.log wolma, 2018-07-31 16:10
Messages (4)
msg322409 - (view) Author: Wolfgang Maier (wolma) * Date: 2018-07-26 10:15
System: Windows7 Enterprise SP1 64-bit
Downloaded the executable installer from python.org (tried both 32- and 64-bit -> same error)

Selected the default user-install and got an almost immediate Error message: The TARGETDIR variable must be provided when invoking this installer.

Clicking OK reveals 0x80070643 - Fatal error during installation and the attached log file.

Rebooting didn't help and I also tried playing with custom installation settings, too, but no success so far.
msg322631 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-07-29 11:46
Thanks.

There is at least one other log file in the same location as the one you attached - the log with "core_JustForMe" in the name is what I need to keep diagnosing this problem.
msg322796 - (view) Author: Wolfgang Maier (wolma) * Date: 2018-07-31 16:10
Oh, sorry, I didn't realize there was another file and it seems I did not keep it so I just ran the installer again to reproduce.
Attached is the new pair of log files.
msg348931 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-08-02 22:53
Sorry about forgetting this - this is an issue with certain security configurations where variables are not passed across the Administrator boundary properly (and the subinstallers are automatically elevated to Administrator).

If you right click the installer and choose "Run as Administrator" and then do the install it should be fine.
History
Date User Action Args
2019-08-02 22:53:43steve.dowersetstatus: open -> closed
resolution: third party
messages: + msg348931

stage: resolved
2018-07-31 16:10:17wolmasetfiles: + Python 3.7.0 (64-bit)_20180731180657.log
2018-07-31 16:10:05wolmasetfiles: + Python 3.7.0 (64-bit)_20180731180657_000_core_JustForMe.log

messages: + msg322796
2018-07-29 11:46:00steve.dowersetnosy: + paul.moore, tim.golden, zach.ware
messages: + msg322631
components: + Windows
2018-07-26 10:16:18wolmasetfiles: + Python 3.7.0 (64-bit)_20180726120531.log
2018-07-26 10:15:52wolmacreate