classification
Title: Any plans to combine collections.OrderedDict with dict
Type: enhancement Stage: resolved
Components: Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: iMath, redstone-cold, rhettinger
Priority: normal Keywords:

Created on 2018-07-25 12:43 by redstone-cold, last changed 2018-07-27 08:27 by iMath. This issue is now closed.

Messages (3)
msg322349 - (view) Author: iMath (redstone-cold) Date: 2018-07-25 12:43
Since Python 3.7,dicts remember the order that items were inserted, so any plans to combine collections.OrderedDict with dict?
https://docs.python.org/3/library/collections.html?#collections.OrderedDict
https://docs.python.org/3/library/stdtypes.html#dict 

BTW, I think it would be better to move "Dictionaries preserve insertion order" part at the end of the doc of https://docs.python.org/3/library/stdtypes.html#dict 
up below the doc for 
class dict(**kwarg)
class dict(mapping, **kwarg)
class dict(iterable, **kwarg)
so that people won't miss the feature when consulting the doc
msg322403 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2018-07-26 06:46
See the related discussion on python-dev and other tracker entries where this was discussed previously.
msg322472 - (view) Author: Philip Lee (iMath) Date: 2018-07-27 08:27
What about my last suggestion :
it would be better to move "Dictionaries preserve insertion order" part at the end of the doc of https://docs.python.org/3/library/stdtypes.html#dict up below the doc for 
class dict(**kwarg)
class dict(mapping, **kwarg)
class dict(iterable, **kwarg)
so that people won't miss the feature when consulting the doc.

在2018年07月26 14时46分, "Raymond Hettinger"<report@bugs.python.org>写道:

Raymond Hettinger <raymond.hettinger@gmail.com> added the comment:

See the related discussion on python-dev and other tracker entries where this was discussed previously.

----------
nosy: +rhettinger
resolution:  -> not a bug
stage:  -> resolved
status: open -> closed

_______________________________________
Python tracker <report@bugs.python.org>
<https://bugs.python.org/issue34221>
_______________________________________
History
Date User Action Args
2018-07-27 08:27:41iMathsetnosy: + iMath
messages: + msg322472
2018-07-26 06:46:11rhettingersetstatus: open -> closed

nosy: + rhettinger
messages: + msg322403

resolution: not a bug
stage: resolved
2018-07-25 12:43:24redstone-coldcreate