classification
Title: 2to3 fails to run on Mac OS X 10.4 PPC 3.0b2
Type: crash Stage:
Components: 2to3 (2.x to 3.x conversion tool) Versions: Python 3.0
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: collinwinter Nosy List: barry-scott, benjamin.peterson, collinwinter
Priority: normal Keywords:

Created on 2008-07-20 08:07 by barry-scott, last changed 2008-08-01 13:57 by benjamin.peterson. This issue is now closed.

Messages (3)
msg70065 - (view) Author: Barry Alan Scott (barry-scott) * Date: 2008-07-20 08:07
$ sw_vers 
ProductName:    Mac OS X
ProductVersion: 10.4.11
BuildVersion:   8S165
$ python3.0
Python 3.0b2 (r30b2:65080, Jul 20 2008, 08:46:13) 
[GCC 4.0.1 (Apple Computer, Inc. build 5341)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> 

$ /Library/Frameworks/Python.framework//Versions/3.0/bin/2to3 a.py
Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework//Versions/3.0/bin/2to3",
line 5, in <module>
    sys.exit(refactor.main("lib2to3/fixes"))
  File
"/Library/Frameworks/Python.framework/Versions/3.0/lib/python3.0/lib2to3/refactor.py",
line 81, in main
    rt = RefactoringTool(fixer_dir, options)
  File
"/Library/Frameworks/Python.framework/Versions/3.0/lib/python3.0/lib2to3/refactor.py",
line 160, in __init__
    self.pre_order, self.post_order = self.get_fixers()
  File
"/Library/Frameworks/Python.framework/Versions/3.0/lib/python3.0/lib2to3/refactor.py",
line 182, in get_fixers
    fix_names = get_all_fix_names(self.fixer_dir)
  File
"/Library/Frameworks/Python.framework/Versions/3.0/lib/python3.0/lib2to3/refactor.py",
line 95, in get_all_fix_names
    names = os.listdir(fixer_dir)
OSError: [Errno 2] No such file or directory: 'lib2to3/fixes'
msg70066 - (view) Author: Barry Alan Scott (barry-scott) * Date: 2008-07-20 08:20
Fixing 2to3 with the full path to the fixes folder gets this traceback:
 $ ./2to3 /dev/null
Traceback (most recent call last):
  File "./2to3", line 5, in <module>
   
sys.exit(refactor.main("/Library/Frameworks/Python.framework//Versions/3.0/lib/python3.0/lib2to3/fixes"))
  File
"/Library/Frameworks/Python.framework/Versions/3.0/lib/python3.0/lib2to3/refactor.py",
line 81, in main
    rt = RefactoringTool(fixer_dir, options)
  File
"/Library/Frameworks/Python.framework/Versions/3.0/lib/python3.0/lib2to3/refactor.py",
line 160, in __init__
    self.pre_order, self.post_order = self.get_fixers()
  File
"/Library/Frameworks/Python.framework/Versions/3.0/lib/python3.0/lib2to3/refactor.py",
line 185, in get_fixers
    mod = __import__(fixer_pkg + ".fix_" + fix_name, {}, {}, ["*"])
ValueError: Empty module name
msg70552 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-08-01 13:57
This is a duplicate of #3131.
History
Date User Action Args
2008-08-01 13:57:38benjamin.petersonsetstatus: open -> closed
nosy: + benjamin.peterson
resolution: duplicate
messages: + msg70552
2008-07-20 08:20:32barry-scottsetmessages: + msg70066
2008-07-20 08:07:06barry-scottcreate