classification
Title: Lib/test/test_pydoc.py failed when ran as a script
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.8, Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: bbayles, miss-islington, serhiy.storchaka, xdegaye
Priority: normal Keywords: patch

Created on 2018-07-21 17:32 by serhiy.storchaka, last changed 2018-07-29 19:52 by serhiy.storchaka. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 8389 merged bbayles, 2018-07-22 00:51
PR 8557 merged miss-islington, 2018-07-29 19:15
Messages (3)
msg322111 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-07-21 17:32
$ ./python Lib/test/test_pydoc.py
...
======================================================================
ERROR: test_mixed_case_module_names_are_lower_cased (__main__.PydocDocTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "Lib/test/test_pydoc.py", line 460, in test_mixed_case_module_names_are_lower_cased
    self.assertIn('xml.etree.elementtree', doc_link)
  File "/home/serhiy/py/cpython/Lib/unittest/case.py", line 1103, in assertIn
    if member not in container:
TypeError: argument of type 'NoneType' is not iterable

----------------------------------------------------------------------

Since it works in 3.6, seems the regression was introduced in issue32031.
msg322640 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-07-29 19:15
New changeset 4e11c461ed39085b8495a35c9367b46d8a0d306d by Serhiy Storchaka (Bo Bayles) in branch 'master':
bpo-34182: Fix test_pydoc running as a script. (GH-8389)
https://github.com/python/cpython/commit/4e11c461ed39085b8495a35c9367b46d8a0d306d
msg322641 - (view) Author: miss-islington (miss-islington) Date: 2018-07-29 19:50
New changeset 990de2f4ca734ddaa196e2af64caafb9c77f29e0 by Miss Islington (bot) in branch '3.7':
bpo-34182: Fix test_pydoc running as a script. (GH-8389)
https://github.com/python/cpython/commit/990de2f4ca734ddaa196e2af64caafb9c77f29e0
History
Date User Action Args
2018-07-29 19:52:59serhiy.storchakasetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2018-07-29 19:50:38miss-islingtonsetnosy: + miss-islington
messages: + msg322641
2018-07-29 19:15:24miss-islingtonsetpull_requests: + pull_request8073
2018-07-29 19:15:17serhiy.storchakasetmessages: + msg322640
2018-07-22 00:51:37bbaylessetnosy: + bbayles
2018-07-22 00:51:16bbaylessetkeywords: + patch
stage: patch review
pull_requests: + pull_request7917
2018-07-21 17:32:53serhiy.storchakacreate