classification
Title: Build failing: use of undeclared identifier '_Py_END_SUPPRESS_IPH' & '_Py_BEGIN_SUPPRESS_IPH'
Type: Stage: resolved
Components: Interpreter Core Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: CuriousLearner, methane, vstinner
Priority: Keywords:

Created on 2018-07-14 21:11 by CuriousLearner, last changed 2018-07-15 00:36 by methane. This issue is now closed.

Messages (3)
msg321662 - (view) Author: Sanyam Khurana (CuriousLearner) * (Python triager) Date: 2018-07-14 21:11
The step for configuration works correctly and gives a makefile.

On running `./make` the following traceback is produced:

```
$ make                                                                                                         
-----------------------------------------------
Modules/Setup.dist is newer than Modules/Setup;
check to make sure you have all the updates you
need in your Modules/Setup file.
Usually, copying Modules/Setup.dist to Modules/Setup will work.
-----------------------------------------------
gcc -Wno-unused-result -Wsign-compare -g -O0 -Wall    -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -Wstrict-prototypes -Werror=implicit-function-declaration   -I. -I./Include     -c ./Modules/posixmodule.c -o Modules/posixmodule.o
./Modules/posixmodule.c:1548:9: error: use of undeclared identifier '_Py_BEGIN_SUPPRESS_IPH'
        _Py_BEGIN_SUPPRESS_IPH
        ^
./Modules/posixmodule.c:1550:9: error: use of undeclared identifier '_Py_END_SUPPRESS_IPH'
        _Py_END_SUPPRESS_IPH
        ^
./Modules/posixmodule.c:4356:5: error: use of undeclared identifier '_Py_BEGIN_SUPPRESS_IPH'
    _Py_BEGIN_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:4364:5: error: expected expression
    else
    ^
./Modules/posixmodule.c:4368:5: error: use of undeclared identifier '_Py_END_SUPPRESS_IPH'
    _Py_END_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:5075:5: error: use of undeclared identifier '_Py_BEGIN_SUPPRESS_IPH'
    _Py_BEGIN_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:5081:5: error: use of undeclared identifier '_Py_END_SUPPRESS_IPH'
    _Py_END_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:5146:5: error: use of undeclared identifier '_Py_BEGIN_SUPPRESS_IPH'
    _Py_BEGIN_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:5157:5: error: use of undeclared identifier '_Py_END_SUPPRESS_IPH'
    _Py_END_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:5376:5: error: use of undeclared identifier '_Py_BEGIN_SUPPRESS_IPH'
    _Py_BEGIN_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:5379:5: error: use of undeclared identifier '_Py_END_SUPPRESS_IPH'
    _Py_END_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:7996:5: error: use of undeclared identifier '_Py_BEGIN_SUPPRESS_IPH'
    _Py_BEGIN_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:8011:5: error: use of undeclared identifier '_Py_END_SUPPRESS_IPH'
    _Py_END_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:8048:5: error: use of undeclared identifier '_Py_BEGIN_SUPPRESS_IPH'
    _Py_BEGIN_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:8050:5: error: use of undeclared identifier '_Py_END_SUPPRESS_IPH'
    _Py_END_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:8074:5: error: use of undeclared identifier '_Py_BEGIN_SUPPRESS_IPH'
    _Py_BEGIN_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:8077:5: error: use of undeclared identifier '_Py_END_SUPPRESS_IPH'
    _Py_END_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:8265:5: error: use of undeclared identifier '_Py_BEGIN_SUPPRESS_IPH'
    _Py_BEGIN_SUPPRESS_IPH
    ^
./Modules/posixmodule.c:8271:5: error: use of undeclared identifier '_Py_END_SUPPRESS_IPH'
    _Py_END_SUPPRESS_IPH
    ^
fatal error: too many errors emitted, stopping now [-ferror-limit=]
20 errors generated.
make: *** [Modules/posixmodule.o] Error 1
```
msg321664 - (view) Author: Sanyam Khurana (CuriousLearner) * (Python triager) Date: 2018-07-14 21:53
This is strange.

I cloned the repo again at some other location, and I can build it successfully.

In my older clone, however, it shows me this error, despite running a `make clean`.

Any idea on what is the problem here?
msg321671 - (view) Author: Inada Naoki (methane) * (Python committer) Date: 2018-07-15 00:36
Sometime, you need to run `make distclean` or `git clean -fdx` to remove wrong caches.
History
Date User Action Args
2018-07-15 00:36:55methanesetstatus: open -> closed

nosy: + methane
messages: + msg321671

resolution: not a bug
stage: resolved
2018-07-14 21:53:53CuriousLearnersetpriority: high ->

type: compile error ->
versions: - Python 3.8
nosy: + vstinner

messages: + msg321664
stage: needs patch -> (no value)
2018-07-14 21:11:56CuriousLearnercreate