This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Multiprocessing not working
Type: performance Stage: resolved
Components: Library (Lib) Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Puneet Singh, docs@python, ned.deily
Priority: normal Keywords:

Created on 2018-06-01 17:05 by Puneet Singh, last changed 2022-04-11 14:59 by admin. This issue is now closed.

Files
File name Uploaded Description Edit
Prog.py Puneet Singh, 2018-06-01 18:27
Messages (3)
msg318433 - (view) Author: Puneet Singh (Puneet Singh) Date: 2018-06-01 17:05
I have attached a sampl program for my project.can anyone help e to solve this multiprocessing problem.I have applied all the tpes of multiprocessing ( map,map_async, starmap, starmap_async, aplly_async) but the result is same that CPU utilisation is one core instead it had to use all of them.

The picture for cpu utilisation an be found in github account:- 
https://github.com/joddiy/multiprocess/issues/1
msg318450 - (view) Author: Puneet Singh (Puneet Singh) Date: 2018-06-01 18:27
Can anyone help me in solving this problem ??
msg318451 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-06-01 18:33
Puneet, sorry but this bug tracker is for reporting issues found with the Python language and its implementation, not for help with programming problems.  Please see the Help page on python.org for suggestions on getting help:

https://www.python.org/about/help/
History
Date User Action Args
2022-04-11 14:59:01adminsetgithub: 77918
2018-06-01 18:33:51ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg318451

resolution: not a bug
stage: resolved
2018-06-01 18:27:14Puneet Singhsetfiles: + Prog.py

messages: + msg318450
2018-06-01 17:05:10Puneet Singhcreate