classification
Title: leak in pythonrun.c?
Type: behavior Stage: resolved
Components: Interpreter Core Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: lekma
Priority: normal Keywords:

Created on 2018-05-27 09:48 by lekma, last changed 2018-05-27 12:52 by lekma. This issue is now closed.

Messages (2)
msg317789 - (view) Author: (lekma) * Date: 2018-05-27 09:48
Am I wrong in thinking 'filename_obj' should be decrefed before the last two return statements in set_main_loader()? If yes, what am I missing?
msg317792 - (view) Author: (lekma) * Date: 2018-05-27 12:52
sorry, my mistake, I missed the format specifier in PyObject_CallFunction()

sorry for the noise
History
Date User Action Args
2018-05-27 12:52:41lekmasetstatus: open -> closed
resolution: not a bug
messages: + msg317792

stage: resolved
2018-05-27 09:48:37lekmacreate