classification
Title: An ortographical typo in Zen of Python text
Type: Stage:
Components: Documentation Versions: Python 3.0, Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: benjamin.peterson, cheDu, georg.brandl, tim.peters
Priority: normal Keywords:

Created on 2008-07-15 15:23 by cheDu, last changed 2008-07-17 15:15 by goodger. This issue is now closed.

Messages (4)
msg69688 - (view) Author: Chester (cheDu) Date: 2008-07-15 15:23
I hope I chose the correct component type for this issue report. Anyway,
if you do  import this  in the Python 3.x interactive interpreter, you
get the Zen of Python by Tim Peters. This text has a line which has an
ortographical typo in it. Please look at this line of text from the Zen
of Python:

There should be one-- and preferably only one --obvious way to do it.

Now this line has the typo I am talking about, and the typo is the lack
of a space before the first dash (actually before the double-hyphen) and
the space after the second dash (or double-hyphen).

Please note that the dash punctuation mark is by ortographical rules
separated from the words, so there are two spaces separating a dash from
the surrounding words. By writing the dashes in the way that are in the
above sentence from the Zen of Python, we don't achieve any effect as
sometimes ortographical rules can be broken to create some special
effect in the sentence (like in a line that uses the asteriskes to
emphasize the word 'right' with writing it as *right*), but here in the
above line it is clearly a normal sentence, not needing any special
effect, which is also incorrect from this point of view. So please fix
the above line like this:

There should be one -- and preferably only one -- obvious way to do it.

Consider the fact that the last sentence is written correctly and that
the dash in it is separated from the surrounding words as the
ortographic rules demand. So having one line of text with an incorrectly
used dash and some other line with the correctly used dash, makes the
whole text either inconsistent or just bad. Okay, it isn't *really* bad
but it's incorrect and it needs a little fix. And it's not too much
trouble to add two missing spaces in that line of text.

I think that ortography is our friend in the Python world. ;)
msg69689 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-07-15 15:30
I'm sorry, but syntax is part of poetry, too. Please stop misusing the
tracker.
msg69712 - (view) Author: Tim Peters (tim.peters) * (Python committer) Date: 2008-07-15 19:35
I'm afraid you missed the joke ;-)  While you believe spaces are
required on both sides of an em dash, there is no consensus on this
point.  For example, most (but not all) American authorities say /no/
spaces should be used.  That's the joke.  In writing a line about "only
one way to do it", I used a device (em dash) for which at least two ways
to do it (with spaces, without spaces) are commonly used, neither of
which is obvious -- and deliberately picked a third way just to rub it in.

This will never change ;-)
msg69881 - (view) Author: Chester (cheDu) Date: 2008-07-17 14:05
You're a strange man, Mr. Peters, a strange man...

On Tue, Jul 15, 2008 at 9:35 PM, Tim Peters <report@bugs.python.org> wrote:

>
> Tim Peters <tim.peters@gmail.com> added the comment:
>
> I'm afraid you missed the joke ;-)  While you believe spaces are
> required on both sides of an em dash, there is no consensus on this
> point.  For example, most (but not all) American authorities say /no/
> spaces should be used.  That's the joke.  In writing a line about "only
> one way to do it", I used a device (em dash) for which at least two ways
> to do it (with spaces, without spaces) are commonly used, neither of
> which is obvious -- and deliberately picked a third way just to rub it in.
>
> This will never change ;-)
>
> ----------
> nosy: +tim_one
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue3364>
> _______________________________________
>
History
Date User Action Args
2008-07-17 15:15:24goodgersetfiles: - unnamed
2008-07-17 14:05:04cheDusetfiles: + unnamed
messages: + msg69881
2008-07-15 19:35:08tim.peterssetnosy: + tim.peters
messages: + msg69712
2008-07-15 15:30:36benjamin.petersonsetstatus: open -> closed
nosy: + benjamin.peterson
resolution: not a bug
messages: + msg69689
2008-07-15 15:23:57cheDucreate