classification
Title: requests.Session doesn't properly handle closed keep-alive sessions
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: Jonathan Lynch, serhiy.storchaka
Priority: normal Keywords:

Created on 2018-05-23 16:46 by Jonathan Lynch, last changed 2018-05-23 17:41 by Jonathan Lynch. This issue is now closed.

Messages (3)
msg317425 - (view) Author: Jonathan Lynch (Jonathan Lynch) Date: 2018-05-23 16:46
When a server reaps a keep-alive session it sends a FIN packet to the client. Normally, requests handles this fine and rebuilds the session on the next request. However, there is an edge case involving network latency that is not properly handled:

If python sends a request at roughly the same time as the server closes the session, then the server will send a RST (as the session is closed). Python receives this RST on what it thought was a valid session and throws an error:

requests.exceptions.ConnectionError: ('Connection aborted.', RemoteDisconnected('Remote end closed connection without response',))

The reason I consider this a bug is because python received the FIN packet before it received the RST. As a result, it shouldn't be surprised when the connection is subsequently aborted. It is an edge case, but the client has enough information available to it that it could have handled it correctly.

The workaround is to set max_retries on the Session via an HTTPAdaptor, but I believe the correct behavior when the FIN is received is to rebuild the session and re-send any requests that were in-flight (rather than throwing an error). Requests correctly handles the FIN packet if there are no in-flight requests, but if there are in-flight requests it ignores it and instead throws an error.
msg317427 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-05-23 16:54
requests is a third-party package. Can you reproduce your issue with the standard Python library?
msg317432 - (view) Author: Jonathan Lynch (Jonathan Lynch) Date: 2018-05-23 17:41
Ah, I'm sorry! I'll open the report over there, closing this.
History
Date User Action Args
2018-05-23 17:41:25Jonathan Lynchsetstatus: open -> closed
resolution: third party
messages: + msg317432

stage: resolved
2018-05-23 16:54:20serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg317427
2018-05-23 16:46:21Jonathan Lynchcreate