classification
Title: fix memory leak in lib/json/scanner.py py_make_scanner
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.8, Python 3.7, Python 3.6, Python 3.4, Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder: possibe typo in json/scanner.py
View: 30877
Assigned To: Nosy List: serhiy.storchaka, yzongyue
Priority: normal Keywords: patch

Created on 2018-05-22 06:55 by yzongyue, last changed 2018-05-22 10:14 by serhiy.storchaka. This issue is now closed.

Files
File name Uploaded Description Edit
截图_2018-05-22_14-53-27.png yzongyue, 2018-05-22 06:55
Pull Requests
URL Status Linked Edit
PR 7044 closed yzongyue, 2018-05-22 07:07
Messages (2)
msg317261 - (view) Author: (yzongyue) * Date: 2018-05-22 06:55
in function py_make_scanner, the last return statements is "return _scan_once"
it should be "return scan_once", or  the memo never clear.
in fact, make_scanner use c_make_scanner rather  than py_make_scanner, so this bug never occur in default
msg317268 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-05-22 10:14
Thank you for your report and pull request, but it is a duplicate of issue30877. This bug was not fixed before because we wanted a test.
History
Date User Action Args
2018-05-22 10:14:12serhiy.storchakasetstatus: open -> closed

superseder: possibe typo in json/scanner.py

nosy: + serhiy.storchaka
messages: + msg317268
resolution: fixed
stage: patch review -> resolved
2018-05-22 07:07:35yzongyuesetkeywords: + patch
stage: patch review
pull_requests: + pull_request6683
2018-05-22 06:55:34yzongyuecreate