classification
Title: remove wrapping of __set_name__ exceptions in RuntimeError
Type: Stage: resolved
Components: Interpreter Core Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: carljm
Priority: normal Keywords:

Created on 2018-05-19 05:41 by carljm, last changed 2018-05-19 05:43 by carljm. This issue is now closed.

Messages (2)
msg317099 - (view) Author: Carl Meyer (carljm) * Date: 2018-05-19 05:41
Per Nick Coghlan in discussion on issue21145:

"I think it would make sense to remove the exception wrapping from the __set_name__ calls - I don't think we're improving the ease of understanding the tracebacks by converting everything to a generic RuntimeError, and we're hurting the UX of descriptor validation cases like this one."

https://github.com/python/cpython/blob/master/Objects/typeobject.c#L7263
msg317102 - (view) Author: Carl Meyer (carljm) * Date: 2018-05-19 05:43
Oops, duplicate of issue33576.
History
Date User Action Args
2018-05-19 05:43:22carljmsetstatus: open -> closed
resolution: duplicate
messages: + msg317102

stage: resolved
2018-05-19 05:41:49carljmcreate