classification
Title: Accept Pathlib paths for sqlite file
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: devala, jreese
Priority: normal Keywords:

Created on 2018-05-14 14:24 by devala, last changed 2018-05-16 02:54 by devala. This issue is now closed.

Messages (3)
msg316508 - (view) Author: (devala) Date: 2018-05-14 14:24
I'd love to be able to pass pathlib paths to sqlite's connect

conn = sqlite3.connect(DB_FILE)
TypeError: argument 1 must be str

The workaround is not hard (str(DB_FILE), but reducing friction in using pathlib would be great.
msg316719 - (view) Author: John Reese (jreese) * Date: 2018-05-15 20:32
Looks like this is already changed for 3.7: see commit a22a127458
msg316756 - (view) Author: (devala) Date: 2018-05-16 02:54
Resolved in 3.7.
History
Date User Action Args
2018-05-16 02:54:12devalasetstatus: open -> closed
resolution: not a bug
messages: + msg316756

stage: resolved
2018-05-15 20:32:55jreesesetmessages: + msg316719
2018-05-15 17:55:12jreesesetnosy: + jreese
2018-05-14 14:24:22devalacreate