classification
Title: Output_Typo_Error
Type: Stage: resolved
Components: Documentation Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, mark.dickinson, vishva_11
Priority: normal Keywords:

Created on 2018-05-09 17:02 by vishva_11, last changed 2018-05-19 11:03 by mark.dickinson. This issue is now closed.

Messages (3)
msg316325 - (view) Author: vishva patel (vishva_11) Date: 2018-05-09 17:02
There is an out[ut typo error in the documentation of python in the module (An Informal Introductio To Python) 3.1.2 section Strings the first example last output the output of:
>>>Isn\'t is given as Isn\t #but it shuld be
>>>Isn\'t
Isn't

so fix it
msg316326 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2018-05-09 17:30
I can't reproduce. I'm looking at https://docs.python.org/3.6/tutorial/introduction.html#strings, and when I test things in Python 3.6.5, I see exactly the same output as given in the documentation:

Python 3.6.5 (default, Mar 29 2018, 15:37:32) 
[GCC 4.2.1 Compatible Apple LLVM 9.0.0 (clang-900.0.39.2)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> '"Isn\'t," she said.'
'"Isn\'t," she said.'
>>> '"Isn\'t," she said.'
'"Isn\'t," she said.'
>>> print('"Isn\'t," she said.')
"Isn't," she said.

Please could you clarify? Perhaps you could copy and paste from an example interpreter session on your machine showing what you're seeing?
msg316370 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2018-05-10 17:20
Marking as pending; we can't take this forward without more input from the OP. As far as I can tell, the documentation is perfectly correct here: I suspect that there was a misunderstanding somewhere along the line.
History
Date User Action Args
2018-05-19 11:03:45mark.dickinsonsetstatus: pending -> closed
stage: resolved
2018-05-10 17:20:16mark.dickinsonsetstatus: open -> pending

type: resource usage ->
assignee: docs@python
components: + Documentation

nosy: + docs@python
messages: + msg316370
resolution: not a bug
2018-05-09 17:30:08mark.dickinsonsetnosy: + mark.dickinson
messages: + msg316326
2018-05-09 17:02:39vishva_11create