classification
Title: ^L character in Lib/email/generator.py
Type: Stage:
Components: Library (Lib) Versions: Python 3.8, Python 3.7, Python 3.6, Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: hexchain, njs
Priority: normal Keywords:

Created on 2018-05-06 07:54 by hexchain, last changed 2018-05-06 08:15 by njs. This issue is now closed.

Messages (3)
msg316229 - (view) Author: (hexchain) Date: 2018-05-06 07:54
There is a "^L" character in line 25 of the Lib/email/generator.py file, and it seems it's there for a long time (since commit 8b3febef2f9).

Is it intended or some carelessness? It does not seem to have any functional impact, though.
msg316230 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-05-06 08:12
It is intended. Emacs use it for separating sections of code. Python parser specially supports this character.
msg316231 - (view) Author: Nathaniel Smith (njs) * (Python committer) Date: 2018-05-06 08:15
That's a "form feed" or "page break" character: https://en.wikipedia.org/wiki/Page_break

Quoting that page: "The form feed character is sometimes used in plain text files of source code as a delimiter for a page break, or as marker for sections of code. Some editors, in particular emacs and vi, have built-in commands to page up/down on the form feed character. This convention is predominantly used in Lisp code, and is also seen in C and Python source code."

It's perhaps a bit old-fashioned, but some of us are old-fashioned kinds of people :-).
History
Date User Action Args
2018-05-06 08:15:25njssetnosy: + njs, - serhiy.storchaka
messages: + msg316231
stage: resolved ->
2018-05-06 08:12:55serhiy.storchakasetstatus: open -> closed

nosy: + serhiy.storchaka
messages: + msg316230

resolution: not a bug
stage: resolved
2018-05-06 07:54:27hexchaincreate