classification
Title: No locale alias mapping key for en_IL
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Mismatch between glibc and X11 locale.alias
View: 20087
Assigned To: Nosy List: licht-t, serhiy.storchaka
Priority: normal Keywords: patch

Created on 2018-05-05 12:18 by licht-t, last changed 2018-05-05 13:33 by serhiy.storchaka. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 6707 closed licht-t, 2018-05-05 12:41
Messages (4)
msg316206 - (view) Author: Licht Takeuchi (licht-t) * Date: 2018-05-05 12:18
The new locale en_IL is added to glibc.
But there is no key for this in the locale alias mapping.
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=146ffc146fe3bf97cd3bc1a649f1ffa8acfa4a0d
https://github.com/python/cpython/blob/master/Lib/locale.py#L850

The locale in latest Ubuntu 18.04 contains en_IL as valid locale, but Python cannot resolve this.
This makes test failure in pandas.
https://github.com/pandas-dev/pandas/issues/20957

```
(pandas-dev) [pandas] locale -a
C
C.UTF-8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IL
en_IL.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
ja_JP.utf8
POSIX
```
msg316207 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-05-05 12:42
This is a duplicate of issue20087. The patch that adds an alias for en_IL was merged, but then reverted.
msg316210 - (view) Author: Licht Takeuchi (licht-t) * Date: 2018-05-05 13:27
en_IL has significant impact because this is English locale and now supported in the latest Ubuntu. Is there any plan to add only en_IL?
msg316212 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-05-05 13:33
This should be discussed in issue20087.
History
Date User Action Args
2018-05-05 13:33:39serhiy.storchakasetmessages: + msg316212
2018-05-05 13:27:58licht-tsetmessages: + msg316210
2018-05-05 12:42:29serhiy.storchakasetstatus: open -> closed

superseder: Mismatch between glibc and X11 locale.alias

nosy: + serhiy.storchaka
messages: + msg316207
resolution: duplicate
stage: patch review -> resolved
2018-05-05 12:41:23licht-tsetkeywords: + patch
stage: patch review
pull_requests: + pull_request6400
2018-05-05 12:18:32licht-tcreate