classification
Title: [typing] __origin__ invariant broken
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.8, Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: apaszke, gvanrossum, levkivskyi
Priority: normal Keywords:

Created on 2018-05-03 18:31 by apaszke, last changed 2018-05-09 01:25 by levkivskyi. This issue is now closed.

Messages (4)
msg316127 - (view) Author: Adam Paszke (apaszke) Date: 2018-05-03 18:31
Hi everyone,

I have a module that needs to inspect type annotations on a few functions. One of the types I need to special case on is typing.Tuple, and I used code like this to detect it:

if getattr(annotation, '__origin__', None) == typing.Tuple:
    ... 
else:
    ...

This was based on the comment from the typing module (Lib/typing.py:609) that specified this particular invariant on the __origin__ attribute:

> __origin__ keeps a reference to a type that was subscripted,
  e.g., Union[T, int].__origin__ == Union;

Everything worked just fine until I checked it on the alpha release of Python 3.7 in my CI. Turns out, that in that release we have

typing.Tuple[str, int].__origin__ == tuple

and not (which is the case in e.g. 3.6)

typing.Tuple[str, int].__origin__ == typing.Tuple


I know this is not a documented attribute, so it can change, but I wanted to highlight that it's either a regression, or the comment will need to be updated, so people won't try to depend on that.
msg316130 - (view) Author: Ivan Levkivskyi (levkivskyi) * (Python committer) Date: 2018-05-03 18:51
Yes, the comment needs to be updated, but as you said, no guaranties about undocumented dunder attribute. We tried to preserve as much of the API as possible in 3.7 after PEP 560, but something needs to be sacrificed (especially in the purely internal API you used).

You may instead use `typing_inspect` library on PyPI, I am not 100% sure it will help in your case, but it has `is_tuple_type` function that should work across several versions of `typing`.
msg316131 - (view) Author: Adam Paszke (apaszke) Date: 2018-05-03 18:55
Of course, I'm not expecting this to be 100% reliable, and so I'm ok with the answer that the comment is now outdated.

I'd like to avoid adding extra dependencies for so simple things, so I guess I'll just special case that in my code for now. It would be great if the typing module had some tools for introspection built in!
msg316302 - (view) Author: Ivan Levkivskyi (levkivskyi) * (Python committer) Date: 2018-05-09 01:25
This is now fixed on master by https://github.com/python/cpython/commit/43d12a6bd82bd09ac189069fe1eb40cdbc10a58c (the comment is updated).
History
Date User Action Args
2018-05-09 01:25:47levkivskyisetstatus: open -> closed
resolution: fixed
messages: + msg316302

stage: resolved
2018-05-04 20:58:21brett.cannonsettitle: __origin__ invariant broken -> [typing] __origin__ invariant broken
2018-05-03 18:55:37apaszkesetmessages: + msg316131
2018-05-03 18:51:00levkivskyisetmessages: + msg316130
2018-05-03 18:34:59serhiy.storchakasetnosy: + gvanrossum, levkivskyi
2018-05-03 18:31:41apaszkecreate