classification
Title: Bug in documentation 3.6: string-methods - str.center
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Alfonso Chavez, docs@python
Priority: normal Keywords:

Created on 2018-04-21 11:50 by Alfonso Chavez, last changed 2018-04-21 11:55 by Alfonso Chavez. This issue is now closed.

Messages (1)
msg315562 - (view) Author: Alfonso Chavez (Alfonso Chavez) Date: 2018-04-21 11:50
Hi. In https://docs.python.org/3/library/stdtypes.html#string-methods says:

str.center(width[, fillchar])

But, I tried in Windows 10 and Ubuntu Server:

>>> var = 'Variable de prueba'
>>> str.center(50, var)
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
TypeError: descriptor 'center' requires a 'str' object but received a 'int'

Then, I tried this:

>>> str.center(var, 50)
'                Variable de prueba                '

I think the documentation should read:
str.center(fillchar[, width])

Version in Windows: Python 3.6.5
Version in Ubuntu Server: Python 3.5.2
History
Date User Action Args
2018-04-21 11:55:21Alfonso Chavezsetstatus: open -> closed
resolution: not a bug
stage: resolved
2018-04-21 11:50:02Alfonso Chavezcreate