classification
Title: Update references to PIL-style arrays
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.8, Python 3.7, Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, pitrou, serhiy.storchaka, skrah
Priority: normal Keywords:

Created on 2018-04-18 18:38 by serhiy.storchaka, last changed 2018-04-18 19:17 by serhiy.storchaka. This issue is now closed.

Messages (5)
msg315458 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-04-18 18:38
The documentation for buffer protocol and memoryview objects contains references to "PIL-style arrays". Since PIL [1] seems dead (it was not ported to Python 3) and superseded by Pillow [2], I think it is worth to update these references. Either rename "PIL-style arrays" to "Pillow-style arrays" or change the wording to more general.

[1] http://www.pythonware.com/products/pil/
[2] http://python-pillow.org/
msg315460 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2018-04-18 18:55
I guess I don't really see much of an issue: The first link for "PIL Python" goes Pillow page and since Pillow is just a fork, the technical term is IMHO "PIL-style".

I like to give credit to original authors.
msg315461 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-04-18 18:59
Indeed, the name of the top-level package is PIL in Pillow.

Unless you want to rewrite the wording or add links I think this issue can be closed.
msg315462 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2018-04-18 19:08
I think I want to leave it as is.  Probably no one is using suboffsets anyway. :-)
msg315463 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-04-18 19:17
Thanks.
History
Date User Action Args
2018-04-18 19:17:00serhiy.storchakasetmessages: + msg315463
2018-04-18 19:08:33skrahsetstatus: open -> closed
resolution: not a bug
messages: + msg315462

stage: resolved
2018-04-18 18:59:27serhiy.storchakasetmessages: + msg315461
2018-04-18 18:55:49skrahsetmessages: + msg315460
2018-04-18 18:38:33serhiy.storchakacreate