classification
Title: libexpat uses HAVE_SYSCALL_GETRANDOM instead of HAVE_GETRANDOM_SYSCALL
Type: Stage: resolved
Components: XML Versions: Python 3.8, Python 3.7, Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, lemburg
Priority: normal Keywords:

Created on 2018-04-14 14:29 by lemburg, last changed 2018-06-25 16:40 by benjamin.peterson. This issue is now closed.

Messages (2)
msg315289 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2018-04-14 14:29
See https://github.com/python/cpython/blob/3.6/Modules/expat/xmlparse.c#L87

The Python configure script tests and sets the variable HAVE_GETRANDOM_SYSCALL.

The solution would be to have Python's config script define HAVE_SYSCALL_GETRANDOM as well, in case it detects the function.
msg320427 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2018-06-25 16:40
Python calls XML_SetHashSalt, so expat itself doesn't need to generate randomness.
History
Date User Action Args
2018-06-25 16:40:01benjamin.petersonsetstatus: open -> closed

nosy: + benjamin.peterson
messages: + msg320427

resolution: not a bug
stage: resolved
2018-04-14 14:29:15lemburgcreate