classification
Title: InteractiveConsole behaves differently on terminal, within script
Type: behavior Stage: resolved
Components: Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Kadir Haldenbilen, terry.reedy
Priority: normal Keywords:

Created on 2018-04-12 14:55 by Kadir Haldenbilen, last changed 2018-04-14 00:22 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
iitests.py Kadir Haldenbilen, 2018-04-12 15:46
iiteswok.py Kadir Haldenbilen, 2018-04-12 15:47
Messages (4)
msg315224 - (view) Author: Kadir Haldenbilen (Kadir Haldenbilen) Date: 2018-04-12 14:55
on terminal push and runcode accepts indentation where required (like for loop etc), within script gives error message

on terminal import works properly and objects can be found  as normal, within script you may need to add module name upfront

simple example
import code
ii = code.InteractiveConsole()
ii.push("for ii in range(3):")
ii.push("    print('i', i)")

you will get normal expected output on terminal, but indentation error within script

ii.push("from time import sleep")
ii.push("sleep(1)")
will sleep 1 sec on terminal, but will give name error
msg315226 - (view) Author: Kadir Haldenbilen (Kadir Haldenbilen) Date: 2018-04-12 15:46
Attached is a non working example
I could not attach a second file, which works OK within script I will attach separately
msg315227 - (view) Author: Kadir Haldenbilen (Kadir Haldenbilen) Date: 2018-04-12 15:47
This script works OK. Compare with iitests.py uploaded before
msg315277 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-04-14 00:22
[For future reference, if I were not closing this, I would ask the following:  Does 'on terminal mean that you started Python in interactive mode and then entered lines in response to the '>>> prompt'?  If so, did you start Python from an actual (non-Python) terminal or console? or from an icon or start menu?  What OS?  When you ran a script, did you run it from the system console or from the file itself?  However, I now consider this a moot point.]

The test for the code module is test.test_code_module, as test_code
tests code objects.  It created a code.InteractiveConsole and calls .interact.  There are no direct unittests of any of the other methods, but most, if not all, including .push, are called directly or indirecty within .interact.  This is all within a script, which you say has problmes.  Input is fed to the interact loop with lines such as

        self.infunc.side_effect = ["try: ham\nexcept: eggs\n",
                                    EOFError('Finished')]

I cannot see that you have identified a real problem.  Your iitests.py fails because it is buggy.  It creates a new interactive console for each line.  When "    print('i', i)" is pushed to a new console, in response to >>>, there *should* be an indentation error.  Similarly, 'sleep(1)' in a new console *should* fail with a NameError.

In iiteswok.py, which you say works, only one console is created.  After adding 'ii.push("")', to tell the console that the statement is complete, and removing unneeded code, the following works for me when run as a script

import code
ii = code.InteractiveConsole()
ii.push("for i in range(3):")
ii.push("    print ('i', i)")
ii.push("")

# prints

i 0
i 1
i 2

Adding

ii.push("from time import sleep")
ii.push("print('start')")
ii.push("sleep(1)")
ii.push("print('stop')")

prints 'start' and 'stop' with a one second delay.
History
Date User Action Args
2018-04-14 00:22:29terry.reedysetstatus: open -> closed

title: InteractiveConsole behaves differently when used on terminal and used within script -> InteractiveConsole behaves differently on terminal, within script
nosy: + terry.reedy

messages: + msg315277
resolution: not a bug
stage: resolved
2018-04-12 15:47:37Kadir Haldenbilensetfiles: + iiteswok.py

messages: + msg315227
2018-04-12 15:46:55Kadir Haldenbilensetfiles: + iitests.py

messages: + msg315226
2018-04-12 14:55:59Kadir Haldenbilencreate