classification
Title: Build on Linux with --enable-optimizations fails
Type: crash Stage: resolved
Components: Build, Tests Versions: Python 3.7
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: fschulze, ned.deily, pitrou
Priority: normal Keywords:

Created on 2018-04-01 08:38 by fschulze, last changed 2018-05-15 13:06 by fschulze. This issue is now closed.

Messages (4)
msg314767 - (view) Author: Florian Schulze (fschulze) Date: 2018-04-01 08:38
While the tests run there is a segfault:
https://travis-ci.org/collective/buildout.python/jobs/360190312#L2529
Started with b2 and still happens in b3, b1 built fine.
msg315086 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2018-04-08 16:14
I wasn't able to reproduce the test_httplib with gcc 5.4.1 on Ubuntu 16.04.

It would be nice if you could get more information about the crash by printing the gdb backtrace.  It seems there is some help here doing that:
https://github.com/springmeyer/travis-coredump
msg316645 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-05-15 12:05
Florian, any further information on this problem?  Are you still seeing it?  Can you supply a backtrace?  Without more information to go on, there's not much we can do to help.
msg316654 - (view) Author: Florian Schulze (fschulze) Date: 2018-05-15 13:06
Due to the TLS changes on pypi.org the buildout I used before doesn't work anymore on Travis and I have now switched to pyenv. If I ever stumble over it again, I will open a new bug with more information.
History
Date User Action Args
2018-05-15 13:06:58fschulzesetstatus: open -> closed

messages: + msg316654
stage: resolved
2018-05-15 12:05:31ned.deilysetnosy: + ned.deily
messages: + msg316645
2018-04-08 16:14:17pitrousettype: crash
2018-04-08 16:14:05pitrousetnosy: + pitrou
messages: + msg315086
2018-04-01 08:38:58fschulzecreate